Unable to Kill firefox process either with Task Mgr or Command line (Vista Home Premium)

RESOLVED INCOMPLETE

Status

()

--
critical
RESOLVED INCOMPLETE
9 years ago
9 years ago

People

(Reporter: kambergk, Unassigned)

Tracking

({hang})

3.5 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-04-12])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; AIRF; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30618; OfficeLiveConnector.1.4; OfficeLivePatch.0.0; .NET CLR 1.1.4322)
Build Identifier: Mozilla 3.5.6

Task Mgr doesn't error, but it doesn't kill the process either.

This has been noted on other websites (See google search)

Reproducible: Always

Steps to Reproduce:
1.Exit Firefox (normally when browser is hanging)
2.Exit using (File/Exit)
3.Firefox window closes, but application is still running.
Attempts to kill application don't work.

Only solution is to reboot. Ugh!
Actual Results:  
Unable to kill application. Have tried to kill process and process tree. No luck. Have tried command line option also:

See below:
C:\Users\Kirk.KIRK_LAPTOP>taskkill /IM firefox.exe /F
SUCCESS: The process "firefox.exe" with PID 3384 has been terminated.

Firefox was not killed, however.

This is the error that is displayed when attempts to relaunch are tried:

Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.



Firefox should be able to be killed.

No theme.

Vista Home Premium, service pack 1.
Using ZoneAlarm security ?  ZA has a long history of just what your describing.  Turning it 'off', does not really turn it off completely, only disabled the GUI.

You have to uninstall ZA, and I would suggest looking for another if that your issue.

Comment 2

9 years ago
I had exactly the same problem (on Windows Vista Business SP2), which made Firefox completely unusable.
I had ZoneAlarm 8.
I upgraded to ZoneAlarm 9. Things seem to work much better now: the problem hasn't re-occured in 24 hours of intensive Firefox use.
Thanks a lot !

Comment 3

9 years ago
I was checking the Event Viewer application logs and came across this which may be of some help to someone.  It may explain why it's not loading/unloading properly...


Windows detected your registry file is still in use by other applications or services. The file will be unloaded now. The applications or services that hold your registry file may not function properly afterwards.  

 DETAIL - 
 2 user registry handles leaked from \Registry\User\S-1-5-21-444971554-1916123363-147537188-1001_Classes:
Process 1624 (\Device\HarddiskVolume2\Program Files\Mozilla Firefox\firefox.exe) has opened key \REGISTRY\USER\S-1-5-21-444971554-1916123363-147537188-1001_CLASSES
Process 1624 (\Device\HarddiskVolume2\Program Files\Mozilla Firefox\firefox.exe) has opened key \REGISTRY\USER\S-1-5-21-444971554-1916123363-147537188-1001_CLASSES

Comment 4

9 years ago
kambergk, this will close shortly without feedback to comment 1 ...
Keywords: hang
Whiteboard: [closeme 2010-04-12]
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
Version: unspecified → 3.5 Branch
You need to log in before you can comment on or make changes to this bug.