Closed Bug 538090 Opened 12 years ago Closed 12 years ago

build warning: "can't read /builds/slave/mozilla-central-linux64/build/toolkit/crashreporter/google-breakpad/src/common/mac/dwarf/Makefile.in: No such file or directory"

Categories

(Toolkit Graveyard :: Build Config, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.3a1

People

(Reporter: dholbert, Assigned: dholbert)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

Filing this bug on this build warning:
>can't read /builds/slave/mozilla-central-linux64/build/toolkit/crashreporter/google-breakpad/src/common/mac/dwarf/Makefile.in: No such file or directory

I think it happens always -- see for example this linux build log from today:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262741102.1262746026.10726.gz

It's caused by this line in toolkit/toolkit-makefiles.sh:
682   toolkit/crashreporter/google-breakpad/src/common/mac/dwarf/Makefile
http://hg.mozilla.org/mozilla-central/annotate/106fa9dc5896/toolkit/toolkit-makefiles.sh#l682

HG blame says that line was added in this changeset:
http://hg.mozilla.org/mozilla-central/rev/56308aac106b
Looking at our directory structure, there is no "google-breakpad/src/common/mac/dwarf" directory, but there is a google-breakpad/src/common/dwarf" directory, with a makefile in it:
http://mxr.mozilla.org/mozilla-central/source/toolkit/crashreporter/google-breakpad/src/common/dwarf/Makefile.in

I'm assuming that's probably what was intended here...
Summary: build warning: "an't read /builds/slave/mozilla-central-linux64/build/toolkit/crashreporter/google-breakpad/src/common/mac/dwarf/Makefile.in: No such file or directory" → build warning: "can't read /builds/slave/mozilla-central-linux64/build/toolkit/crashreporter/google-breakpad/src/common/mac/dwarf/Makefile.in: No such file or directory"
Attached patch trivial fixSplinter Review
Pretty sure this should fix it.  I'm doing a full local build with this, just to make sure the warning goes away and nothing scary happens...
Assignee: nobody → dholbert
Status: NEW → ASSIGNED
Comment on attachment 420266 [details] [diff] [review]
trivial fix

Yup, this fixes it.  Now instead of the warning, I get:
> Creating directory toolkit/crashreporter/google-breakpad/src/common/dwarf
[...]
> creating toolkit/crashreporter/google-breakpad/src/common/dwarf/Makefile

and those are the only mentions of "dwarf" in the whole build log.

Requesting r=philor, since it's to code that he added, just to make sure I'm not missing something.
Attachment #420266 - Attachment description: fix → trivial fix
Attachment #420266 - Flags: review?(philringnalda)
Comment on attachment 420266 [details] [diff] [review]
trivial fix

The only things you are missing are that it's not the fault of what I added, which represented the state of things at the time, but rather it's all Ted's fault, for not changing it when he moved the makefile in bug 514188, and also that there's a permanent rubber-stamp from whoever owns the build system at the time to go ahead and fix missing and no longer correct lines in toolkit-makefiles.sh, so please land it with "blanket-rs=ted" rather than "r=philor".
Attachment #420266 - Flags: review?(philringnalda) → review+
(In reply to comment #4)
> (From update of attachment 420266 [details] [diff] [review])
> The only things you are missing are that it's not the fault of what I added,
> which represented the state of things at the time, but rather it's all Ted's
> fault, for not changing it when he moved the makefile in bug 514188,

Sorry -- I only did minimal hg-archeology, and I apparently misapplied blame.  Marking as regression from bug 514188.

Landed fix with blanket-r=ted:
http://hg.mozilla.org/mozilla-central/rev/9365650ac51b
Blocks: 514188
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: regression
Resolution: --- → FIXED
Flags: in-testsuite-
Target Milestone: --- → mozilla1.9.3a1
Changes in toolkit-makefiles.sh mostly don't matter FWIW, since the build system will regenerate Makefiles on the fly if need be. They're just a convenience. More specifically, I thought I updated this file in my patch, but I guess I missed it.
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.