themes/classic/communicator/communicator.css should not include prefpanels.css

VERIFIED FIXED

Status

SeaMonkey
Themes
P2
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Simon Fraser, Assigned: andreww)

Tracking

({classic})

Trunk
PowerPC
Mac System 8.5
classic

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3++][fix ready], URL)

(Reporter)

Description

18 years ago
prefpanels.css is not present in the mac classic skin, yet communicator.css still 
includes it. This causes the app to stall at startup in Mac.

What I don't understand is why this bug only shows up when *not* using jar files. 
Do missing CSS files not cause stalls when using jars?
(Reporter)

Updated

18 years ago
Keywords: classic
(Reporter)

Comment 1

18 years ago
nsbeta3 keyword. Trivial fix, risks are high (unpredictable behaviour with 
missing CSS files, and this affets the first window the user sees).
Keywords: nsbeta3
(Reporter)

Comment 2

18 years ago
Erm, "risks" there is "risks if not fixed"
*** Bug 53812 has been marked as a duplicate of this bug. ***
applying this patch fixes really bad skin switching bugs when switching from 
modern to classic. we need this bug fixed.
Keywords: nsmac1
(Assignee)

Comment 5

18 years ago
raising priority as it has broad consequensts for skin switching.
Priority: P3 → P2
(Reporter)

Comment 6

18 years ago
Patch:

Index: mozilla/themes/classic/communicator/mac/communicator.css
===================================================================
RCS file: /cvsroot/mozilla/themes/classic/communicator/mac/communicator.css,v
retrieving revision 1.7
diff -r1.7 communicator.css
17,18d16
< @import url(chrome://communicator/skin/prefpanels.css);
< 

Comment 7

18 years ago
Nominating for ++.   Removing this one line from one file must be done and I 
recommend doing this for nsbeta3 because it fixes some really nasty skin 
switching bugs.  Low risk high win.  
Assignee: hangas → andreww
Whiteboard: nsbeta3+
(Assignee)

Comment 8

18 years ago
Accepting. Working on this today.
Status: NEW → ASSIGNED
(Assignee)

Comment 9

18 years ago
I have this ready in my tree .
Whiteboard: nsbeta3+ → [nsbeta3+][fix ready]
(Reporter)

Comment 10

18 years ago
We need this on the branch too; it kills mac classic skin otherwise.

Comment 11

18 years ago
nsbeta3++
Whiteboard: [nsbeta3+][fix ready] → [nsbeta3++][fix ready]
(Assignee)

Comment 12

18 years ago
ok will check into both locations...
(Assignee)

Comment 13

18 years ago
ok now fishing for a reviewer and approver.
(Assignee)

Comment 14

18 years ago
fixed branch and trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
work ok on Mac (2000-09-27-11-MN6).
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.