Do not allow add-on versions to have multiple files which are supported on ALL platforms

RESOLVED FIXED in 4.x (triaged)

Status

P3
minor
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: aryx, Unassigned)

Tracking

unspecified
4.x (triaged)
x86
Windows XP

Details

(Whiteboard: [bonus], URL)

This is because there are 2 files uploaded for that version, both for all platforms.  Looks like one is in the sandbox and one is public.  -> jorge for solutions :)
Assignee: nobody → jorge
Severity: normal → minor
Priority: -- → P4
Target Milestone: --- → Future
I deleted the sandboxed version. However, the public version doesn't exist on the server. I've contacted the author about this, and told him to upload a new file with a different version number.

The duplicate button should disappear within a couple of hours.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Comment 3

9 years ago
There is another addon which has the same problem-https://addons.mozilla.org/en-US/mobile/search?q=lazyclick&cat=all&advancedsearch=1&as=1&appid=60&lver=any&atype=0&pp=20&pid=3&sort=&lup=


Should we allow users to upload multiple files for the same version with same option(in this case,all platforms)?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 5

9 years ago
Dual Add to Firefox buttons and going to details page dual Continue to Download buttons are present:
Office Options - https://preview.addons.mozilla.org/en-US/firefox/addon/87458/
iSyndica Tools - https://preview.addons.mozilla.org/en-US/firefox/addon/80211/
WordReference Translator - https://preview.addons.mozilla.org/en-US/firefox/search?q=WordReference+Translator&cat=all

Comment 6

8 years ago
multiple Download Now buttons are present  going to details page :

Search Tools- https://preview.addons.mozilla.org/z/en-US/seamonkey/addon/9583/
I've fixed the add-ons listed so far by deleting all the duplicate files. However, we should definitely mitigate the problem by only showing one button even if there are multiple files for the same version with compatibility for ALL.
Assignee: jorge → nobody
Priority: P4 → P3
Target Milestone: Future → 5.12

Comment 8

8 years ago
This problem happens on the versions page as well. See- https://preview.addons.mozilla.org/en-US/firefox/addon/10868/versions/?page=1#version-0.5

That version of that add-on has two files for the option "ALL"
comment 8 is the only place I still see this
Target Milestone: 5.12 → 4.x (triaged)

Updated

8 years ago
Duplicate of this bug: 590506

Updated

8 years ago
Duplicate of this bug: 566897

Updated

8 years ago
Whiteboard: [bonus]

Updated

8 years ago
Blocks: 599043

Updated

8 years ago
No longer blocks: 599043
Depends on: 599043

Updated

8 years ago
Summary: Multiple download buttons for extension → Do not allow add-on versions to have multiple files which are supported on ALL platforms

Comment 13

8 years ago
Another add-on found with two Add to Firefox buttons:
https://addons.mozilla.org/en-US/firefox/addon/live-search/

Updated

8 years ago
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.