[z] Add groups model/interactions with users model

RESOLVED FIXED in 5.6

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P1
normal
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: clouserw, Assigned: davedash)

Tracking

unspecified

Details

(Whiteboard: [z][gh:master])

(Reporter)

Description

9 years ago
dd is doing the users/sessions in bug 534026 so this kinda goes along with that.  We need group stuff too.
Can I get more details?  E.g. where these things are set, what tables to look at.  Not necessary, because I can poke around.
(Reporter)

Comment 2

9 years ago
Yeah, I filed this yesterday in mid-meeting because we needed a place holder.  Basically this is about setting up, at a minimum, the backend of groups.  So, right now we have 2 tables: groups and groups_users.  There are some standard functions in the groups model for getting names and membership stuff, but there are also two files outside of it; both components:  simple_auth.php and simple_acl.php.

When we create a group we give it a permissions flag (something like editors:*) which says what actions can be performed by those users.  simple_acl is what checks the current user against that flag.  You can find documentation on the permissions at https://wiki.mozilla.org/Update:Remora_Permissions

For this bug I'm looking for group CRUD, some kind of ACLs (either a django version or a duplicate of simple_acl), and an easy way to check permissions in the code with the ACLs - probably one or more decorators.  And then documentation for how to do it. :)
/davedash/zamboni/tree/538276-simple-acl shouldn't get approved until bug 539108 is resolved.
Status: NEW → ASSIGNED
Depends on: 539108
Whiteboard: [z] → [z][gh:/davedash/zamboni/tree/538276-simple-acl]
rebased with master
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [z][gh:/davedash/zamboni/tree/538276-simple-acl] → [z][gh:master]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.