Last Comment Bug 538383 - -moz-box-shadow does not follow rounded borders correctly defined by -moz-border-radius
: -moz-box-shadow does not follow rounded borders correctly defined by -moz-bor...
Status: RESOLVED DUPLICATE of bug 527695
[DUPEME?]
:
Product: Core
Classification: Components
Component: Layout: View Rendering (show other bugs)
: 1.9.1 Branch
: x86 Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on: 466572
Blocks: border-radius
  Show dependency treegraph
 
Reported: 2010-01-07 08:15 PST by Pascal Chevrel:pascalc
Modified: 2014-01-11 13:42 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
comparizon rendering between webkit and gecko (206.42 KB, image/png)
2010-01-07 08:15 PST, Pascal Chevrel:pascalc
no flags Details
testcase showing the bug (683 bytes, text/html)
2010-01-07 08:15 PST, Pascal Chevrel:pascalc
no flags Details

Description Pascal Chevrel:pascalc 2010-01-07 08:15:24 PST
Created attachment 420551 [details]
comparizon rendering between webkit and gecko

Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.2b5) Gecko/20091204 Firefox/3.6b5

If you define by css rounded borders to a block and then add a bow shadow, there are painting glitches of the shadow around the rounded border. See attached image to compare the rendering to the one of Chromium.

This issue affects both 3.6b5 and 3.7 trunk builds.

I will also attach a testcase showing the bug.
Comment 1 Pascal Chevrel:pascalc 2010-01-07 08:15:56 PST
Created attachment 420552 [details]
testcase showing the bug
Comment 2 philippe (part-time) 2010-01-07 15:37:59 PST
dupe of bug 527695 ?
Comment 3 Sebastian Zartner 2011-06-22 05:48:45 PDT
This is indeed a duplicate of bug 527695.
Comment 4 sjw 2013-11-22 08:44:54 PST

*** This bug has been marked as a duplicate of bug 527695 ***

Note You need to log in before you can comment on or make changes to this bug.