Generating builtin.cpp on solaris broken

VERIFIED FIXED in flash10.1

Status

Tamarin
Tools
P2
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: Chris Peyer, Assigned: Brent Baker)

Tracking

unspecified
flash10.1
x86
Solaris
Bug Flags:
flashplayer-qrb +
flashplayer-triage +

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Generating the builtins on solaris results in a different builtin.cpp than all the other platforms.  The builtin.cpp generated will not allow the shell to build:


"tamarin-redux/core/builtin.cpp", line 696: Error: Infinity is not defined.
"tamarin-redux/core/builtin.cpp", line 697: Error: Infinity is not defined.
"tamarin-redux/core/builtin.cpp", line 1075: Error: Infinity is not defined.
"tamarin-redux/core/builtin.cpp", line 1076: Error: Infinity is not defined.
Flags: flashplayer-triage+
Flags: flashplayer-qrb?

Updated

8 years ago
Assignee: nobody → leon.sha
Status: NEW → ASSIGNED
Flags: flashplayer-qrb? → flashplayer-qrb+
Priority: -- → P2
Target Milestone: --- → flash10.1

Comment 1

8 years ago
I don't see this problem. Maybe it has been fixed.
(Assignee)

Comment 2

8 years ago
I am able to reproduce the problem.

using tr rev 3814 (last known rev that compiles on solaris due to nanojit changes)

>$ cd core; ./builtin.py
>$ cd ../objdir; ../configure.py --enable-shell; make -j2

"core/builtin.cpp", line 4715: Error: Infinity is not defined.
"core/builtin.cpp", line 4716: Error: Infinity is not defined.
"core/builtin.cpp", line 5094: Error: Infinity is not defined.
"core/builtin.cpp", line 5095: Error: Infinity is not defined.
4 Error(s) detected.

info:
- asc.jar version is 11524
- running python 2.5.4
- OS 5.10 Generic_139555-08

Comment 3

8 years ago
I can not build builtin.cpp correctly with python 2.4 or 2.5.4. I am using python 2.6. That maybe the reason why I can not reproduce the problem. Try to install python 2.6 from sunfreeware.com and set the default python to 2.6.
# ln -sf /usr/local/bin/python2.6 /usr/bin/python
That maybe solve this problem.
Also can you attach the generated builtin.cpp here?
(Assignee)

Comment 4

8 years ago
Created attachment 431901 [details]
builtin.cpp 

built using Python 2.5.4 (r254:67916, Feb 28 2009, 04:55:37)
(Assignee)

Comment 5

8 years ago
Using python 2.6.2 does generate a correct builtin.cpp

Comment 6

8 years ago
Is this fix to upgrade/require to 2.6.2 then?  Is there anything else to do?
(Assignee)

Comment 7

8 years ago
"fix" is to upgrade/use python 2.6.2 on solaris

Updated

8 years ago
Assignee: leon.sha → brbaker
(Assignee)

Comment 8

8 years ago
I have updated the buildbot solaris buildslaves to use python 2.6.2
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 9

8 years ago
Thanks a lot.
(Assignee)

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.