Allow specifying a default version for new bugs

RESOLVED DUPLICATE of bug 45043

Status

()

RESOLVED DUPLICATE of bug 45043
9 years ago
9 years ago

People

(Reporter: mozilla.org, Unassigned)

Tracking

Details

(Whiteboard: DUPME?)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1
Build Identifier: 

There is no way to specify a default version number on a per-product basis when creating a bug.  The code which determines the version number (in enter_bug.cgi) has these comments:

# IF this is a cloned bug,
# AND the clone's product is the same as the parent's
#   THEN use the version from the parent bug
# ELSE IF a version is supplied in the URL
#   THEN use it
# ELSE IF there is a version in the cookie
#   THEN use it (Posting a bug sets a cookie for the current version.)
# ELSE
#   The default version is the last one in the list (which, it is
#   hoped, will be the most recent one).
#
# Eventually maybe each product should have a "current version"
# parameter.

Notice the last line.  I think it's high time that Bugzilla implemented this suggestion.

The reason this is a problem for me is that I want to have "unspecified" be the default version, but I can't figure out how to make that the "last" version in the list.

Reproducible: Always

Updated

9 years ago
Whiteboard: DUPME?

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 45043
You need to log in before you can comment on or make changes to this bug.