If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Thunderbird composer To: line autocomplete should sort contacts in a better way (Wrong Steve Issue)

RESOLVED DUPLICATE of bug 497722

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 497722
8 years ago
8 years ago

People

(Reporter: Irving Popovetsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0


You want to send a message to several people with popular names.    In the composer,  on the To:/Cc:/etc line,  you begin typing the popular name, let's use Steve as an example.

You type Steve and a drop-down autocomplete box appears,  showing all of the Steves in your address book.   However, they appear to be sorted in a totally arbitrary way!   At least in my case they are not alphabetical,  nor by order of most emailed,  no sense to it at all.   Using Apple Address Book.

I'm sure this has lead to many embarrassing situations where messages are sent to the wrong Steve.  I think the same issue exists with MS Outlook.  

Gmail and Apple Mail sort contacts automatically by the Steves you communicate with most.   This is a very smart way to do things.    I propose Thunderbird adopts this frequency-based sort order,  or gives users a choice of sort order.

Reproducible: Always
frequency is broke in v3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Summary: Thunderbird composer To: line autocomplete should sort contacts in a smarter way (Wrong Steve Issue) → Thunderbird composer To: line autocomplete should sort contacts in a better way (Wrong Steve Issue)
Version: unspecified → 3.0
Duplicate of bug: 497722
You need to log in before you can comment on or make changes to this bug.