Linux Install fails:Fatal error [-616] Extract of XPCOM failed

VERIFIED INVALID

Status

SeaMonkey
Installer
P3
normal
VERIFIED INVALID
18 years ago
13 years ago

People

(Reporter: fenella, Assigned: Sean Su)

Tracking

Trunk
Other
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
When I install Linux build using (2000-09-22-08 M180, it does not complete. In 
the middle of installation, it came out an error:
Fatal error [-616] Extract of XPCOM failed.
fenella and I already know that this is invalid. but I wanted a bug on it for
two reasons:

1) someone will hit it again
2) twalker has seen it

Here's what was happening:

fenella was low on space on /tmp

I found this out using strace:

strace -f ./netscape-installer >& log.txt
[we get the failure, and exit]
cat log.txt | grep "open" | grep "tmp"

[pid 22624] open("/tmp/.tmp.xi.0/xpcom.xpi", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 8
[pid 22624] open("/tmp/.tmp.xi.0/browser.xpi", O_WRONLY|O_CREAT|O_TRUNC, 0666) =
10
[pid 22624] open("/tmp/.tmp.xi.0/mail.xpi", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 12
[pid 22624] open("/tmp/.tmp.xi.0/AIM.xpi", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 14
[pid 22624] open("/tmp/.tmp.xi.0/psm.xpi", O_WRONLY|O_CREAT|O_TRUNC, 0666) = 16
[pid 22624] open("/tmp/.tmp.xi.0/spellchecker.xpi", O_WRONLY|O_CREAT|O_TRUNC,
0666) = 18
[pid 22624] open("/tmp/.tmp.xi.0/talkback.xpi", O_WRONLY|O_CREAT|O_TRUNC, 0666)
= 20
[pid 22624] open("/tmp/.tmp.xi.0/deflenus.xpi", O_WRONLY|O_CREAT|O_TRUNC, 0666)
= 22
[pid 22624] open("/tmp/.tmp.xi.0/langenus.xpi", O_WRONLY|O_CREAT|O_TRUNC, 0666)
= 24
[pid 22624] open("/tmp/.tmp.xi.0/xpcom.xpi", O_RDONLY) = 24
[pid 22624] open("/tmp/.tmp.xi.0/bin/libplds4.so", O_WRONLY|O_CREAT|O_TRUNC,
0666) = -1 ENOENT (No such file or directory)
open("/tmp/", O_RDONLY|O_NONBLOCK|0x10000) = 4

so the problem was we were failing to extract libplds4.so because we were low on
space.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
this is probably worth a relnote.

adding verah to the cc list.
Keywords: relnote3

Comment 3

18 years ago
I've been seeing the following terminal screen message for several days.  It
doesn't stop me from testing. 


*** QfaServices is being registered
*** Deferring registration of sample JS components
************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Factory not registered (may be tried again)
[nsIModule::registerSelf]"  nsresult: "0x80040155
(NS_ERROR_FACTORY_REGISTER_AGAIN)"  location: "<unknown>"  data: no]
************************************************************
-*- filepicker: registering (all right -- a JavaScript module!)
*** Registering sample JS components
Move window by 399.5,299.5
New location for profile registry and user profile directories is ->
/u/twalker/.mozilla

Updated

18 years ago
QA Contact: gemal → gbush
twalker: what does that have to do with this bug? That is the sample 
javascript component demostrating deferred registration by returning 
NS_ERROR_FACTORY_REGISTER_AGAIN.

Are you seeing this in installer builds? If so somehow the sample.js component 
mistakenly has gotten into the product. If not, then it would seem even less 
relevant to a bug about installer failure.

Comment 5

18 years ago
This is what I've been seeing...fanella mentioned that I'd been seeing this bug. 
 Just thought I'd put in the info that I was seeing and let those that know what 
it means sort it out.  I don't know the code or what the errors mean. 

Comment 6

18 years ago
vfy
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.