Crash After selecting over window borders

VERIFIED DUPLICATE of bug 53358

Status

()

Core
Selection
P3
critical
VERIFIED DUPLICATE of bug 53358
17 years ago
17 years ago

People

(Reporter: BenB, Assigned: mjudge)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Reproducible: Intermittend, roughly every 20th relevant action - often enough to
cause a crash every 10-15 mins or so during work.

Reproduce:
1. Open Mailnews HTML composer.
2. Press primary mouse button in text, either in the addessing widget or the
content area.
3. While holding the mouse button, move the mouse pointer out of the composer.
(This will select the text, as intended.)

Actual result:
Crash.
(Reporter)

Updated

17 years ago
Severity: normal → critical
Keywords: crash, dogfood, nsbeta3
Can we have a trace of the crash or a talkback report?
(Reporter)

Comment 2

17 years ago
I'm running my own, optimized build :-/

Comment 3

17 years ago
Ben: Any chance that your build environment is messed up?  Can you reproduce on
a standard optimized build (delivered from mozilla or Netscape?)  I tried this
repeatedly on the Netscape sweetlou (optimized) build, and couldn't crash at all
(even when my selection caused various auto-scrolling events).
Has anyone else been able to reproduce this?
If I don't hear about any reproducibility, I can't mark this as dogfood-plus.
(Reporter)

Comment 4

17 years ago
Removing dogfood keyword per jar's comment.

I don't know, if it happens with mozilal.org builds (you don't want me to use
PR2, do you?). Will eat that dogfood to test.
Keywords: dogfood → stackneeded

Comment 5

17 years ago
I have been trying this on win98 using the comm build from 2000092208 and have
not been able to reproduce this. I am asking QA to test this on linux to see if
they can reproduce

Comment 6

17 years ago
sw update
Whiteboard: [Need Info]

Comment 7

17 years ago
yes it does crash on linux at random times..cannot reproduce every time...
Fenella also confirmed this....

Comment 8

17 years ago
Linux (2000-22-08 M18)
I have seen it crash once but cannot reproduce with another try.
(Reporter)

Comment 9

17 years ago
Readding dogfood nomination, since I'm not the only one seeing this.
Keywords: dogfood

Comment 10

17 years ago
I've been seeing something similar to this on Win32, I believe.  I can crash 
when I click in the addressing field (ie. new message).

Ben - do you crash doing this?
1. New message
2. Click in addressing field and slightly move the mouse. Crash.

Here is my stack trace.

   nsBindingManager::WalkRules 
                                              
[d:\builds\seamonkey\mozilla\layout\xbl\src\nsBindingManager.cpp, line 806]
     
   StyleSetImpl::WalkRuleProcessors 
                                              
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp, line 2012]
     
   StyleSetImpl::HasStateDependentStyle 
                                              
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp, line 1109]
     
   nsCSSFrameConstructor::ContentStatesChanged
                                              
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp, 
line 9777]
     
   StyleSetImpl::ContentStatesChanged 
                                              
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp, line 1183]
     
   PresShell::ContentStatesChanged 
                                              
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 3620]
     
   nsXULDocument::ContentStatesChanged 
                                              
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1592]
     
   nsEventStateManager::SetContentState 
                                              
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
2578]
     
   nsEventStateManager::GenerateMouseEnterExit
                                              
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
1523]
     
   nsEventStateManager::PreHandleEvent 
                                              
[d:\builds\seamonkey\mozilla\layout\events\src\nsEventStateManager.cpp, line 
306]
     
   PresShell::HandleEventInternal 
                                              
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4252]
     
   PresShell::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 4192]
     
   nsView::HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 379]
     
   nsViewManager2::DispatchEvent 
                                              
[d:\builds\seamonkey\mozilla\view\src\nsViewManager2.cpp, line 1429]
     
   HandleEvent 
                                              
[d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 68]
     
   nsWindow::DispatchEvent 
                                              
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 685]
     
   nsWindow::DispatchWindowEvent 
                                              
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 702]
     
   nsWindow::DispatchMouseEvent 
                                              
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3892]
     
   ChildWindow::DispatchMouseEvent 
                                              
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 4100]
     
   nsWindow::ProcessMessage 
                                              
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2985]
     
   nsWindow::WindowProc 
                                              
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 951]
     
   USER32.dll + 0x1268 (0x77e71268) 
                                               
See the stack trace, it's a dup of bug 53358
(Reporter)

Comment 12

17 years ago
Lisa, yes, not hard to reproduce. I just need to click around on an empty
addressing widget 5 or 6 times, and crash :-/.
Keywords: stackneeded
Whiteboard: [Need Info]

*** This bug has been marked as a duplicate of 53358 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
verified dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.