After migration from SeaMonkey 1.1 to 2.0 the first subscribed newsgroup gets lost

RESOLVED INCOMPLETE

Status

MailNews Core
Networking: NNTP
--
critical
RESOLVED INCOMPLETE
8 years ago
5 years ago

People

(Reporter: Wolfgang Cernohorsky, Unassigned)

Tracking

({dataloss})

unspecified
x86
Windows XP
dataloss
Bug Flags:
blocking-seamonkey2.0.3 -

Firefox Tracking Flags

(blocking-thunderbird3.0 -)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; GTB6.3; .NET CLR 2.0.50727; InfoPath.1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.6) Gecko/20091206 SeaMonkey/2.0.1

After an existing SeaMonkey 1.x profile is migrated, the first subscribed newsgroup of an newsgroup account is lost.
When I resubscribe this newsgroup and restart SeaMonkey the "next" first subscribed newsgroup is lost.

Reproducible: Always

Steps to Reproduce:
1. Install SeaMonkey/2.0.1 and migrate your profile with an existing newsgroup account.
2. Start SeaMonkey Mail/Newsgroups Window, look at the subscribed newsgroups
3. if first subscribed newsgroup is lost, resubscribe it and restart SeaMonkey.
Actual Results:  
First subscribed newsgroup is lost. After resubscribe this newsgroup and restart SeaMonkey, the next subscribed newsgroup is also lost, and so on.


Happens also under Windows 2000.
Not reproduceable when starting with a new profile.
Can you reproduce with Thunderbird v3.0.1?
Severity: normal → critical
Flags: blocking-seamonkey2.0.3?
Keywords: dataloss
Version: unspecified → SeaMonkey 2.0 Branch
(Reporter)

Comment 2

8 years ago
Yes, same behaviour.
Component: MailNews: Message Display → Profile Migration
Product: SeaMonkey → MailNews Core
QA Contact: message-display → profile-migration
Version: SeaMonkey 2.0 Branch → 1.9.1 Branch
blocking-thunderbird3.0: --- → ?

Comment 3

8 years ago
Not confirmed, not blocking a security update for this.
Flags: blocking-seamonkey2.0.3? → blocking-seamonkey2.0.3-
Likewise, not confirmed and its unclear what Wolfgang was migrating to/from.

The SM 1.x -> 2.0 uses a totally different path to TB 2.0.x -> TB 3.0.x (assuming that's what it was tested with) so these would be different bugs even if they did exhibit the same issue.
blocking-thunderbird3.0: ? → -
Back to SeaMonkey product for this very bug then.
Component: Profile Migration → Startup & Profiles
Product: MailNews Core → SeaMonkey
QA Contact: profile-migration → profile-manager
Version: 1.9.1 Branch → SeaMonkey 2.0 Branch
(Reporter)

Comment 6

8 years ago
(In reply to comment #4)

I tried to migrate from SM 1.1.18 to SM 2.0.1 and from SM 1.1.18 to TB 3.0.1, both with same results.
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.23) Gecko/20090825 SeaMonkey/1.1.18] (release)

I created a new profile <NewProfileName> and subscribed to 1+ groups on news.mozilla.org.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1b3pre) Gecko/20090223 SeaMonkey/2.0a3] (release)

I created a new profile.
I migrated with |seamonkey -P <NewProfileName> -migration|.
The group(s) was there before/after restart.

WorkForMe.

***

Can you reproduce with SeaMonkey v2.0.3? (give detailed steps to reproduce)
(Reporter)

Comment 8

8 years ago
I tried it with SeaMonkey v2.0.3 the same way as you did and it looks ok.
Then I played with different flags (junk status and priority disabled, status, lines and flag enabled) and read some newsgroups postings and mail from my mail account, everything ok.

After 3 or 4 restarts of SeaMonkey, the first subscribed newsgroup then has disappeared.

I really don't know, why this happens and what is the reason for that...
(Reporter)

Comment 9

8 years ago
Update: I can reproduce it now!

Scenario:
SeaMonkey/1.1.18 with one ore more newsgroups account (with username&password required for news server access) and newsgroups with some articles marked unread.
SeaMonkey/2.0.3 with a new empty profile.
Migration with |seamonkey -P <NewProfileName> -migration|.
Groups are there after restart.

Open the first subscribed newsgroup (no need to authenticate against the news server) and mark an unread article as read and then as unread again.
Close SeaMonkey.
Start SeaMonkey again and open Mail&Newsgroups window - first subscribed newsgroups is lost.
Resubscribe lost newsgroup, restart SeaMonkey.
Next subscribed newsgroup is lost and so one.

Can you reproduce this?

Comment 10

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.8) Gecko/20100205 SeaMonkey/2.0.3

I can confirm for version SeaMonkey 2.0.3

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a3pre) Gecko/20100310 SeaMonkey/2.1a1pre

Works For Me

Can you try and reproduce with SeaMonkey 2.1a1pre? (2.1a1pre isn't stable enough for everyone's daily use yet).
Summary: After migration to SeaMonkey 2.0.1 the first subscribed newsgroup gets lost → After migration from SeaMonkey 1.1 to 2.0 the first subscribed newsgroup gets lost

Comment 11

8 years ago
(In reply to comment #10)

> I can confirm for version SeaMonkey 2.0.3

I used steps from Comment 9 .
(Reporter)

Comment 12

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a3pre) Gecko/20100311 SeaMonkey/2.1a1pre

Same problem, sorry.

Comment 13

8 years ago
Testing you in empty new profile?

I cannot reproduce in 2.1a1pre still.
(Reporter)

Comment 14

8 years ago
Not reproduceable with an empty new profile.

Described symptoms appear only after an migration from an SeaMonkey 1.1.18 existing profile to SeaMonkey 2.0.3 or SeaMonkey/2.1a1pre.

So either my existing 1.1.8 profile is corrupted or the migration went wrong.
But with SeaMonkey 1.1.8 I never have seen this kind of problem...
(Reporter)

Comment 15

8 years ago
And it has something to do with my profile:
My news.rc file in SeaMonkey 1.1.8 looks like this:
news.group.a! [lots of spaces] [article numbers]
news.group.b! [lots of spaces] [article numbers]
news.group.1: [article numbers]
news.group.2: [article numbers]
news.group.3: [article numbers]
...

So the first 2 newsgroups are unsubscribed, but still the number of articles are stored in the rc-file.

After the steps from Comment 9 the news.rc file looks like this:
news.group.a! [lots of spaces] [article numbers]news.group.b! [lots of spaces] [article numbers]news.group.1: [article numbers]
news.group.2: [article numbers]
news.group.3: [article numbers]
...

No carriage return-line feed after the article numbers of the unsubscribed newsgroups. And this is why the first subscribed newsgroup gets lost...

When I delete the unsubsribed newsgroups from the news.rc file before migration, everything is ok and this may be the reason, why this failure isn't reproduceable in every case.

Comment 16

8 years ago
As far as I know, migration just copies this file, so it needs to be the core newsgroup code that mangles those entries, moving the MailNews Core for that.

Thanks for investigating, this really looks like a smoking gun to me!
Component: Startup & Profiles → Networking: NNTP
Product: SeaMonkey → MailNews Core
QA Contact: profile-manager → networking.nntp
Version: SeaMonkey 2.0 Branch → unspecified

Comment 17

6 years ago
Tony, can you reproduce?
(In reply to Wayne Mery (:wsmwk) from comment #17)
> Tony, can you reproduce?

Something that only happened when migrating a profile from SeaMonkey 1.1 to 2.0? I wouldn't know how, I don't have any old-style profile left. I even think that profile migration from xpfe Suite has been removed (at least from current trunk; don't know how far it dates back).

FWIW, the newsrc.news.mozilla.org and newsrc.news.skynet.be (for the only NNTP servers I'm still connecting to) in my profile are "clean" and much more recent than when I migrated to the first SeaMonkey "suiterunner" alpha I could lay hands on.

Oh, and BTW this is billed as a WinXP-x86 bug; I'm on linux-x86_64.

I think this bug has become old hat for SeaMonkey but I'd like second opinions:
- Mnyromyr: is this bug still meaningful for SeaMonkey?
- wsmwk (or someone): is this bug still (or has it ever been) meaningful for Thunderbird?

If the answers to both questions are No, then I suppose this bug can be closed WONTFIX or maybe even INVALID.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.