Closed Bug 538549 Opened 12 years ago Closed 12 years ago

disable disk cache usage after exceed maximum disk cache size

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 443067

People

(Reporter: graypx, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 2.0.50727)

when downloading a large files (from depositfiles, rapidshare or etc) these files are placed into the disk cache. If the maximum disk cache is (for example) set to 200mb, and you will download a few files (about 100Mb) the disk cache exceed its maximum size (for example 400Mb - reported be CacheStatus plugin GUID:cache@status.org) 
after that FF is not using disk cache anymore (that slow down browsing and increase the traffic)

Reproducible: Always

Steps to Reproduce:
1. clean install and install some plugins to view cache size and contents
2. some surfing, and download some large files
3. goto step 2 until stored disk cache size exceeds its maximum size
Actual Results:  
no disk cache usage anymore

Expected Results:  
prevent to store large files into the disk cache or delete it after that
Component: Disability Access → File Handling
Product: Firefox → Core
QA Contact: disability.access → file-handling
Version: unspecified → Trunk
Duplicate of Firefox bug 443067?
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443067
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.