'Clear Location(url) Bar History' does not work for current window

VERIFIED FIXED

Status

()

P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: cmaximus, Assigned: bugs)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
***Overview Description: 

  There is a button in the History Preferences category that allows one to clear
the type-in history drop down in the location bar. Pressing this button does not
clear the type in history for any already opened windows.

***Steps to Reproduce: 

1) Open a browser window and type in and surf to any link.

2) Edit|Preferences. Navigator|History. Click 'Clear Location Bar'

3) Click OK to close prefs and click the triangle at the right margin of the 
location bar to expose the type-in history.

***Actual Results: 

The button becomes disabled instantly but the history still remains. The history
list clears in a new window (although it's still there for the pre-existing windows).
If you type in a new site the history list resets and now only the new entry is available
(in all windows)

***Expected Results: 

The type in history list should immediatly clear from all existing windows.

***Build Date & Platform Info: 

All platforms with the 2000092212 builds.

***Additional Information:

I believe this to be a regression associated with Ben's checkin to fix bug 52966.
Builds that don't have that fix don't have this bug and vice versa.
(Reporter)

Comment 1

18 years ago
adding regression keyword.
Keywords: regression
nav triage team: we think this is FIXED. if incorrect, please reopen and
renominate. thanks. 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.