No user preference to disable automatic offline mode.

RESOLVED DUPLICATE of bug 437453

Status

()

Firefox
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 437453
9 years ago
8 years ago

People

(Reporter: Jeffrey Hurwit, Unassigned)

Tracking

3.5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

Firefox polls the OS for a network connection on startup and while running, and automatically switches to "Work Offline" mode if not found. If the connection is interrupted even for a moment, FF goes to offline mode (and does not return to online mode when the connection is restored). Since FF no longer has the (on|off)line status indicator/toggle that was originally on the Mozilla Comm. Suite (and is still on SeaMonkey-- the add-on "Work Offline" places it back into FF), the user's first indication that FF has automatically gone offline is when s/he attempts to load a page, and gets the "offline mode" warning page.

There is no user preference in FF to disable this behaviour.

Reproducible: Always




Thunderbird and SeaMonkey both have the user preference 'offline.autoDetect', which can be set to 'False' to disable this behaviour. Though this preference is listed in the Mozilla knowledgebase as a 'Mail and News' setting, I am told by a SeaMonkey user (see the thread "Automatic offline mode" in news.mozilla.org/mozilla.wishlist) that it controls autodetection for the entire SeaMonkey Suite (newsreader, MUA, and the web browser, too). What's more, he reports that it is set to 'False' by default.

One only needs to search the web for "firefox offline mode disable" (which is listed in Google's drop-down box as a frequently performed search) to read the numerous posts in various support forums from discommoded, inconvenienced, and irritated users seeking some fix or work-around to disable this behaviour, because there is no user option to shut it off. As a work-around, users of Firefox for Linux can set 'toolkit.networkmanager.disable' to 'True', which instructs Firefox to ignore what the Linux network manager reports; no one has found an internal work-around for FF on other platforms.

There are at least TWO add-ons available...

Always On
http://yellosoft.us/index.php?id=88
https://addons.mozilla.org/en-US/firefox/addon/8502

Stay In Online Mode
http://netticat.ath.cx/StayOnline/StayOnline.htm
https://addons.mozilla.org/en-US/firefox/addon/13233

...that have no other functionality than to disable autodetect in FF. They were written in the absence of a user preference, so that users may gain control over this feature (the author of Always On states that he wrote it for himself). The comments of appreciation in the forums and on addons.mozilla.org are only a small indication of how desirable and needful this preference is. The necessity to write an add-on (read: kludge, in this instance) to substitute for a preference is an even stronger argument.

Note: Bug 505715 appears to be a different issue, although it may be related to this one.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.5 Branch

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437453
You need to log in before you can comment on or make changes to this bug.