getLocaleShortDateFormat function missing/undefined

RESOLVED INVALID

Status

Thunderbird
General
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Steven Gerber, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Lightning/1.0b2pre Thunderbird/3.0

getLocaleShortDateFormat function missing/undefined?
Breaks "More Functions for Address Book" AKA "More Columns for Address Book".
Error: uncaught exception: [Exception... "'[JavaScript Error: "getLocaleShortDateFormat is not defined" {file: "chrome://morecols/content/utils.js" line: 121}]' when calling method: [nsIAbViewListener::onSelectionChanged]" nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)" location: "JS frame :: chrome://messenger/content/addressbook/addressbook.xul :: onselect :: line 1" data: yes]
Usually in dateFormat.js?

Reproducible: Always

Steps to Reproduce:
1. Install MoreFunctionsForAddressBook
2. Open Error Console
3. Open Address Book
4. Check Error Console
Actual Results:  
Error: uncaught exception: [Exception... "'[JavaScript Error: "getLocaleShortDateFormat is not defined" {file: "chrome://morecols/content/utils.js" line: 121}]' when calling method: [nsIAbViewListener::onSelectionChanged]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://messenger/content/addressbook/addressbook.xul :: onselect :: line 1"  data: yes]

Expected Results:  
(No error)

Disabling MoreFunctionsForAddressBook prevents the error -- obviously not the solution.
Is getLocaleShortDateFormat() usually defined in dateFormat.js?
(Reporter)

Comment 1

8 years ago
Created attachment 420860 [details]
More Functions for Address Book (TB3)
Yes, Tb2 had a misnamed getLocaleShortDateFormat(), and the trunk that became Tb3 has had a more accurately named initLocaleShortDateFormat() since November 2006. While we may at some point do a Firefox-like "no function can ever again be removed," we're a long way away from that right now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
OK
Before I start hacking it, is there an easy fix?
Should I just change the call from getLocaleShortDateFormat() to initLocaleShortDateFormat()?  Do I need to worry about any side effects?
You need to log in before you can comment on or make changes to this bug.