Firefox 3.6 RC1 crashes with Xmarks installed on OS X 64 bit

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: brndnsh, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

When the Xmarks Bookmarks and Password Sync extension is installed, Firefox 3.6 cannot launch.

Reproducible: Always

Steps to Reproduce:
1. Install Firefox 3.6 RC1 on OS X 64 bit
2. Install the Xmarks bookmark sync extension
3. Restart Firefox, and the program quits on startup
Actual Results:  
Firefox cannot start unless you use safe mode.

Expected Results:  
Firefox should start with Xmarks installed.

As far as I can tell, this does NOT happen on 32 bit builds of OS X.  On my older MacBook Pro (32 bit only), Firefox works fine with Xmarks.
Can you give a stacktrace? https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report
If it crashes on startup you will have to open it in safe mode to get the stracktraces.
(Reporter)

Comment 2

9 years ago
Kinda weird, I don't see anything at all in about:crashes, and there's nothing relevant in the Crash Reports folder.  This is the only output from the console when I try to launch Firefox:

10/1/10 00:21:18	com.apple.launchd.peruser.502[151]	([0x0-0x1fe1fe0].org.mozilla.firefox[99348]) Exited with exit code: 1

Comment 3

9 years ago
Hi, i have the same problem, crash on startup with exit code:1 if xmarks is installed.
MacPro 10.6.2
My investigations:
What makes no diffrence to startup crash 
 - 32- or 64-Bit Kernel
 - repair file system permissions
 - 3.6b1 - 3.7a1
 - delete profile and propertie, install xmark extension in fresh profile
 - older xmark versions

What makes it work:
 - new clean user account
 - same profile with FF 3.5.x works fine

So I think that there must something wrong with my home dir! But my system is very stable and there are no other issues! I made a start with the xcode instrument tool to watch io operations. There are not very much, open prefs.js-1 and after the rename to prefs.js it crashes only with the exit code: 1

Any help to debug this better?
And good to hear that i'am not alone :-)

Regards
Roman
(Reporter)

Comment 4

9 years ago
This is still an issue in the final release of Firefox 3.6.
(Reporter)

Comment 5

9 years ago
Looks like Mozilla Weave also causes this crash on launch.  The behavior is exactly the same as the crash with Xmarks installed - no crash report is generated by Firefox, and Console.app just shows that Firefox exited with exited with code 1.

Comment 6

7 years ago
Roman, do you still see this?

Brandon (reporter) hasn't "used Firefox or Xmarks in a while.  Not
sure if it's still an issue."
Severity: normal → critical
Keywords: crash
Whiteboard: [closeme 2011-10-11]

Comment 7

7 years ago
I gave up a few days after my post and started with a new profile. With actual FF releases i had never this kind of problem.

Comment 8

7 years ago
Thanks Roman. Let's call this WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2011-10-11]
You need to log in before you can comment on or make changes to this bug.