logitech setpoint, back and forward buttons is writing playing card symbols into the search field

RESOLVED DUPLICATE of bug 441783

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 441783
8 years ago
8 years ago

People

(Reporter: Marcus, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

I have an MX Revolution mouse with Logitech Setpoit drivers and I noticed the when I use the back and forward buttons in Firefox they are writing a playing card symbol (spades, hearts, diamonds or clubs) into my search window (I have activated "Search when typing", but sometimes in the "extra search field next to the urlbar") and sometimes I'm taken back or forward, sometimes not.

This problem does not exist in my Windows environment nor IE6-8/Chrome.

There is a work around, by using the Alt-Left and Alt-Right keystrokes instead of the 'back' and 'forward' commands, but sometimes it stops to work in Firefox so a part of the problem is still there, but the playing cards are gone. (Not good enough though)

Reproducible: Always

Steps to Reproduce:
1. Mouse from Logitech that uses the setpoit program ex MX Revolution
2. Install setpoint
3. Activate "search when typing" or use the urlbar/searchbar next to the url
4. Push the back or forward button
Actual Results:  
A playing card should appear.

Expected Results:  
Go back or forward and no playing card should appear.

Comment 1

8 years ago
I can confirm this issue with both Firefox 3.6.x and Firefox 4.0 beta.

Maybe the text input should be filtered in some way.

This issue doesn't exist on other browsers like IE or Opera.

Comment 2

8 years ago
The issue is not specific to the search field, it does happen with every edit box of the Firefox UI.

Comment 3

8 years ago
This bug should be marked as a duplicate of #441783

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 441783
You need to log in before you can comment on or make changes to this bug.