The default bug view has changed. See this FAQ.

Mozilla color image handling code is different from the bgcolor color handling code

RESOLVED FIXED in Future

Status

()

Core
ImageLib
P3
normal
RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: xkahn, Unassigned)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16 i686)
BuildID:    2000091312

The bgcolor attribute rounds to one color in the color cube, and the image code
rounds to another in 16 bit mode.  (At least on Linux.)  Check out this URL to
test:
http://hotwired.lycos.com/webmonkey/00/37/stuff2a/complete_websafe_216/test.html

Razorfish wrote an article on the problem which can be found here:
http://hotwired.lycos.com/webmonkey/00/37/index2a.html?tw=design

This link ( http://www.zoned.net/~xkahn/boxes.png ) shows mozilla rendering this
page on Linux in 16bit True color mode (here is the xdpyinfo)
  default visual id:  0x22
  visual:
    visual id:    0x22
    class:    TrueColor
    depth:    16 planes
    available colormap entries:    64 per subfield
    red, green, blue masks:    0xf800, 0x7e0, 0x1f
    significant bits in color specification:    6 bits


Reproducible: Always
Steps to Reproduce:
1. Load the URL in 16bit mode.
2. Look for boxes within boxes.  Each one you see is a bug in the color
handling.

Actual Results:  Boxes within boxes everywhere!

Expected Results:  A nice clean set of solid boxes.

Gimp says:  CCCCCC bgcolor is: C8CCC8, and CCCCCC image is dithered to: c8c8c8
and c0ccc0.

Comment 1

17 years ago
You have to look carefully, some of the images that have a high luminosity (like
cccc99) are easier to see a problem with than those which are less luminous. I
saw this too on my 16-bit system.

Comment 2

17 years ago
setting bug status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 3

17 years ago
Updating QA Contact
QA Contact: paw → tpreston

Comment 4

17 years ago
Adding myself to cc list

Updated

17 years ago
Blocks: 61530

Comment 5

16 years ago
All pnunn bugs reassigned to Pav, who is taking over
the imglib.
Assignee: pnunn → pavlov
Status: ASSIGNED → NEW

Comment 6

16 years ago
Seeing this on build 2001070108 win32 on win98

setting os to all

are there any plans to fix this?
OS: Linux → All
Is this a duplicate of bug 1759?
dbaron, I don't think so, since in this bug no transparency is involved (as I
understand it)

Comment 9

10 years ago
Test page looks fine in Firefox 2.0.0.2 on K/Ubuntu 6.10.

Comment 10

10 years ago
Sorry, it turns out i'm running with 24 bit colors. KDE doesn't appear to have a color depth setting in its GUI. I'll test and report back if it's OK.

Updated

10 years ago
Assignee: pavlov → nobody
QA Contact: tpreston → imagelib
We no longer do dithering.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.