If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

with viewer, we are creating a "preferences.js" file when a pref is toggled

VERIFIED FIXED in M7

Status

()

Core
Preferences: Backend
P3
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

ramiro showed this to me yesterday:

bring up viewer, toggle "Debug | Style | Widget Render Mode " from Gtk to
Native, and a preferences.js file will get created.

I talked to mcmullen, and he thinks the problem is that we aren't initializing
prefs the right way.  (In the new world, we need to get the prefs service, etc.)

I'll need to do the same thing in the viewer main as we do in nsAppRunner.cpp's
main.
Status: NEW → ASSIGNED
Target Milestone: M7
marking for m7.  m6 is packed for me.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 2

19 years ago
This is all fixed already. Marking it so.

Comment 3

19 years ago
Actually, what happens now is that a file will be created in the cwd called
"default_prefs.js". The reason this is not really using the right location for
the prefs file is that nsIFileLocator is not a standalone component (see bug
#5571) - it lives in appshell dll. Therefore, when code in viewer tries to get
the nsIFileLocator service, it fails, and falls back on the default.

Anyway, preferences in viewer are now at least working (using the cwd location),
and so this bug can be closed.
thanks for fixing this.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
verified

Updated

18 years ago
Component: libPref → Preferences: Backend

Comment 6

18 years ago
Moving all libPref component bugs to new Preferences: Backend component.  
libPref component will be deleted.
You need to log in before you can comment on or make changes to this bug.