Closed Bug 538812 Opened 12 years ago Closed 11 years ago

Context menu of entries in the "List all tabs" menu operates on the currently active tab and not the selected one

Categories

(Firefox :: Tabbed Browser, defect)

3.6 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 545592

People

(Reporter: bjlockie, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [3.6.x]?)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b5) Gecko/20100101 Namoroka/3.6b5
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2b5) Gecko/20100101 Namoroka/3.6b5

The currently displayed tab is closed when a tab is selected from the "List all tabs" menu.

Reproducible: Always

Steps to Reproduce:
1. left mouse click "List all tabs"
2. right mouse click on a tab name
3. left click on "Close tab" on the popup menu

Actual Results:  
The tab that is currently displayed is closed.

Expected Results:  
The tab that is selected in the "List all tabs" list should be closed.
WFM with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100109 Minefield/3.7a1pre (.NET CLR 3.5.30729) ID:20100109042837. Does this happen with the release candidate of 3.6? A bunch of bugs have been fixed since the last beta.
Confirmed on 3.6RC1 on Linux
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is also happening with Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.3a1pre) Gecko/20100109 Minefield/3.7a1pre for me
Depends on: 515095
This happens for all the operations you can do inside the context menu of those entries.
Keywords: regression
Hardware: x86_64 → All
Summary: closes the current tab, not the one selected from the "List all tabs" menu. → Context menu of entries in the "List all tabs" menu operates on the currently active tab and not the selected one
Whiteboard: [3.6.x]?
Version: unspecified → 3.6 Branch
OS: Linux → All
Duplicate of this bug: 549548
The reason this occurs is because the tab context menu is not supposed to show up when right-clicking the all tabs menu. See bug 545592.

Henrik, this could be part of the test set for bug 551921.
Blocks: cuts-cruft
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545592
No longer depends on: 515095
No longer blocks: cuts-cruft
You need to log in before you can comment on or make changes to this bug.