Firefox.exe does not close on hitting the "X"

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Remco V, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; nl; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

When closing firefox (from normal mode and private mode browsing) it does not always really close. The form closes but by going to taskmanager and the processes tab, firefox.exe still exists (Most of the times even with 100% cpu usage for 1 core) I've had this problem since the 3.5.7 update (I had the latest previous version before this one).

This bug occurs to me on both my laptop (old D610) as on my laptop for work (Asus x59sl) and my desktop (i7core with hd4870 and 6gb memory).

Reproducible: Sometimes

Steps to Reproduce:
1.Open Firefox, start browsing.
2.Close firefox when you usually do..
3.Try to start firefox again and it displays a message that firefox is still running - so open taskmanager and kill the firefox.exe process to continue browsing.
Actual Results:  
Firefox.exe does not close.

Expected Results:  
Firefox.exe should not be running after hitting the "X" button on the right top of the window.

The only addon I have for all computers is chatzilla.
I cannot reproduce on Windows 7, Vista, or XP. You can only "kill" firefox by going to File->Exit, clicking the X at the top leaves it partially open for faster startup, as i understand it.

Resolved Invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

8 years ago
Then how come when I click the firefox taskbar icon I'm getting a popup saying that Firefox is still running and I first have to close it before starting it again? I can only start firefox again when I kill the firefox.exe process.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 3

8 years ago
Here's a screenshot: http://i49.tinypic.com/ra88ys.png

Translated from dutch to english:  "Firefox is still running but not responding. To open a new window please first close the existing Firefox-process, or reboot your system."
Please try safe-mode or/and a new profile:

http://support.mozilla.com/en-US/kb/Safe+Mode
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 5

8 years ago
Safe mode -> disabled every plugin/addon.
Closed Firefox,  opened it again and enabled all plugins/addons.  This seems to have fixed the issue for 2 computers. Still odd that both with a clean install had this issue.

Thanks Ria!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WORKSFORME

Updated

8 years ago
Duplicate of this bug: 539069
You need to log in before you can comment on or make changes to this bug.