Bookmarks toolbar moved to Menu Line: bookmarks fail to layout correctly on startup

RESOLVED WORKSFORME

Status

()

Firefox
Toolbars and Customization
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Pgr, Unassigned)

Tracking

3.5 Branch
x86_64
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)

When the Bookmarks Toolbar has been moved to the right of the Menu Bar, when starting Firefox the Bookmarks get laid out as if the window was narrower than it actually is. Maximizing and Restoring corrects the problem.

Reproducible: Always

Steps to Reproduce:
1. Go to View-->Toolbars-->Customize, drag the Bookmarks Toolbar to the right of the menu bar (next to the "Help" menu). Click done to exit the Customize dialog.
2. Fill up the Toolbar with folders or bookmarks so it is almost full.
3. Have the Firefox window unmaximized, with a normal web browsing width. Observe the Bookmarks layout, which should be correct.
4. Restart Firefox. 
Actual Results:  
The first few bookmarks show correctly, but then a » sign shows indicating extra bookmarks exist (see attachment 1 [details] [diff] [review]), but it shouldn't, because a lot of empty space is there that should be used to layout the bookmarks.

Expected Results:  
To see the expected results, just maximize the Firefox window, and then Restore it. The bookmarks now take up all available space, and no » is required. See attachment 2 [details] [diff] [review].

Speculation: it looks as though, on start up, the Bookmarks are laid out before the Firefox window is fully set up, and the width that is taken into consideration as available is narrower, for some reason.
(Reporter)

Comment 1

8 years ago
Created attachment 420953 [details]
The bookmarks fail to use all available space.
(Reporter)

Comment 2

8 years ago
Created attachment 420954 [details]
After maximizing and restoring, the bookmarks now lay out correctly.
Can you still reproduce this with the latest 3.6 nightly?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-1.9.2/
Version: unspecified → 3.5 Branch
(Reporter)

Comment 4

8 years ago
The problem appears to be solved in the latest 3.6 nightly:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2pre) Gecko/20100111 Namoroka/3.6pre (.NET CLR 3.5.30729)

Did you fix it? Great!

I confess I've known this bug for ages, since the 2.x days, and never bothered to report it, shame on me. And now it was fixed in a matter of hours... what a lesson.

Thanks.
This could be fixed by Bug 447571. Not sure if it is entirely the same bug.
I'll close this bug as WFM, per comment 4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.