After migration from 3.0.2 to 3.4.4 in a query list there' s a lots of missing value for Hw (Plt) field.

RESOLVED INVALID

Status

()

Bugzilla
Query/Bug List
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Csaba, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.13) Gecko/2009082121 Iceweasel/3.0.6 (Debian-3.0.6-1)
Build Identifier: 3.4.4

Hi!

I migrated from 3.0.2 to 3.4.4. Everything went fine, but if i try to search, in some bugs i can' t see values for HW (PLT) field.

Checking in the old and the new databases, the values are the same in the bugs table for rep_platform column.

We' ve got about 150.000 bugs in the database, and in the first 61439 every rep_platform value are identified by a string (like x86, arm, etc), but after this above 61439 the bugs.rep_platform value is identified by a number (which can be binded to rep_platform table).

If the bugs.rep_platform value is a string, i can see it in the search list in both of the installation, if it' s a number, i can see it only in the old installation (3.0.2), in the new installation i can see only the numbers like 9 or 13.

Reproducible: Always

Actual Results:  
The problem is i can' t see the values of the rep_platform values in a query list if this field is identified by a number instead of a string - in the bug table.

Expected Results:  
I' d like to see every rep_platform value in a search list.

If i change the rep_platform value of a bug - in the bugs table on the new installation -, this value will be changed in the query list, too, so presumably it' s fetched from the bugs.rep_platform field.

If i' m not mistaken, normally the Plt/ Hw/ Rep_platform field is not viewable in the query list, so to reach it You' ve add it on the "Change columns" page (colchange.cgi).
(Reporter)

Comment 1

8 years ago
Any additional comments.

Above bug number 61439 if i take a look on a bug, i don' t have the correct value of the Platform field, i always receive the first value from the rep_platform table regarding to the sortkey field.

If i' m not mistaken, bugzilla should pull the platform information from bug_platform table regarding to bug_id, but it looks like it pulls it from the bugs table.

Temporarily i could write a script to fetch this datas from bug_platform table and load into bugs, but is there any better solution?

Comment 2

8 years ago
Bugzilla doesn't link bugs.rep_platform and rep_platform.id together. This means you have a customized 3.0.2 installation.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

8 years ago
Well, it' s possible, unfortunately i don' t know too much about the older (3.0.2) installation. I just launch the conversion, and i lose the HW field on bugs above bug 61439. Is there any way to restore it? From the old installation, what is the best way to receive the HW field for a bug? I mean from the database, what table(s), what field(s)?

Normally, should bugzilla pull the platform datas from bugs.rep_platform field?

Thanks.
(Reporter)

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

8 years ago
This is a support question. See http://www.bugzilla.org/support/ for help. This Bugzilla installation is only used to track bugs in the core code.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.