If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

<textbox readonly="false" /> renders textbox as readonly

RESOLVED DUPLICATE of bug 118683

Status

()

Core
XUL
--
minor
RESOLVED DUPLICATE of bug 118683
8 years ago
8 years ago

People

(Reporter: Jakub Ondrusek, Unassigned)

Tracking

1.9.1 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091221 Gentoo Firefox/3.5.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.6) Gecko/20091221 Gentoo Firefox/3.5.6

A XUL textbox is always read-only if the "readonly" attribute is set, regardless of whether it's value is "true" or "false"

Reproducible: Always

Steps to Reproduce:
<textbox readonly="true" value="this cannot be modified" />
<textbox readonly="false" value="this value cannot be modified either" />
Actual Results:  
Both textboxes are rendered as read-only.

Expected Results:  
The first textbox should be read-only, the second one should not.
(Reporter)

Updated

8 years ago
Version: unspecified → 1.9.1 Branch

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 118683
You need to log in before you can comment on or make changes to this bug.