Go-To-Date function seems one day off in full century years (except 2000)

RESOLVED DUPLICATE of bug 238632

Status

Calendar
General
RESOLVED DUPLICATE of bug 238632
8 years ago
8 years ago

People

(Reporter: mk, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.18pre) Gecko/20080917 Sunbird/0.9

Hi, I have noticed the following behaviour in my Sunbird 0.9: In full century years (1700,1800,1900,2100), when trying to add a date on a 1st day of the month, Sunbird seems to be exactly one day off. But the year 2000 is an exception to this behaviour.

Reproducible: Always

Steps to Reproduce:
1) I used the "Go To Date" function for something like May 1st, 1800.
2)  Sunbird briefly displays April 30th in that box instead, but switches to May 1st, 1800 in the main calender view.
3) When I try to add a date, the drop down and selection popup do not match (they are one day off).
4) I first noticed that when trying to directly go to May 1st 1800, so I think it has to do with accessing the first day of a month in full centuries (1700, 1800, 1900).
5) Funnily it does NOT apply to the year 2000.

Actual Results:  
One day off, meaning:
1st of month marked, but when trying to add a date Sunbird suggests the previous day, e.g. 31st of the month before


While most people wont be adding data into years like 1900, 1800, 1700, it is still a bug that should be fixed. I don't know whether this might be part of a larger problem.

BTW thanks for making Sunbird, I love it.

Comment 1

8 years ago
Works for me using Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.9pre) Gecko/20100228 Calendar/1.0b2pre. Bug 238632 was fixed via Bug 350, resolving as duplicate.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 238632
You need to log in before you can comment on or make changes to this bug.