If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Error reporting shouldn't be displayed on mozilla.com

VERIFIED FIXED

Status

www.mozilla.org
General
--
major
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: clouserw, Assigned: wenzel)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://www.mozilla.com/en-US/firefox/all-older.html has a bunch of warnings about undefined variables on it right now, e.g.

Notice: Undefined variable: options in /data/www/www.mozilla.com-svn/includes/product-details/firefoxDetails.class.php on line 987

Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /data/www/www.mozilla.com-svn/includes/product-details/firefoxDetails.class.php on line 987

Those shouldn't show up in production.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 539008
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 2

8 years ago
Yea, not a dupe. We are fixing these bugs, but they shouldn't be shown even so.
Status: REOPENED → NEW
(Reporter)

Updated

8 years ago
Duplicate of this bug: 539028
Severity: normal → major
Assignee: server-ops → nobody
Component: Server Operations: Web Content Push → www.mozilla.com
Product: mozilla.org → Websites
QA Contact: mrz → www-mozilla-com
http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/tags/production/.htaccess?view=markup

lines 6-9 need to be commented out
(Assignee)

Comment 5

8 years ago
I can do that.
Assignee: nobody → fwenzel
Status: NEW → ASSIGNED
(Assignee)

Comment 6

8 years ago
I commented out these lines directly on the prod tag: r59528. I'll close this when it's showing up live, or if you see it faster than I do, go ahead and close this for me.
(Assignee)

Comment 7

8 years ago
Looks fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Verified FIXED; thanks!
Status: RESOLVED → VERIFIED
(Assignee)

Comment 9

8 years ago
Why has this shown up again?
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
that's because Mike pushed the whole file instead of just his changed with RC2: http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/tags/production/.htaccess?r1=60084&r2=60210
(Assignee)

Comment 11

8 years ago
Beltzner: http://viewvc.svn.mozilla.org/vc/projects/mozilla.com/tags/production/.htaccess?revision=60210&view=markup :(

Fixed again in r60405.

Reed: Isn't there a bug about removing these PHP development flags from the .htaccess file altogether?
r60710 and r60711 moves the debug block from .htaccess to config.inc.php on trunk and stage
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Verified FIXED; certainly not visible on production now.
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.