Closed Bug 539023 Opened 10 years ago Closed 10 years ago

update the release notes pref

Categories

(Firefox for Android Graveyard :: General, defect, blocker)

Fennec 1.1
defect
Not set
blocker

Tracking

(fennec1.0+)

VERIFIED FIXED
Tracking Status
fennec 1.0+ ---

People

(Reporter: aakashd, Assigned: mfinkle)

Details

Attachments

(1 file)

Thanks to the patch in bug 537186 , 

pref app.releaseNotesURL points to http://www.mozilla.org/projects/%APP%/%VERSION%/releasenotes/ . Unfortunately, APP will point to fennec rather than mobile on branded builds. Right now, the release notes page for 1.0 is pointed to https://www.mozilla.com/en-US/mobile/1.0/releasenotes/
The link is used in about:Firefox under the "release notes" link
tracking-fennec: --- → 1.0+
This isn't related to branding or %APP%. The problem is just that we moved the release notes to mozilla.com from mozilla.org at some point and didn't update this pref at all. The right value is commented out in prefs.js, just a matter of switching it in.
Summary: release notes pref points to fennec/1.0 rather than mobile/1.0 on branded builds → update the release notes pref
Assignee: nobody → buchanae
Assignee: buchanae → nobody
(In reply to comment #3)
> http://www.mozilla.com/en-US/mobile/1.0/releasenotes/  exists
> http://www.mozilla.com/en-US/mobile/1.0.0/releasenotes/ does not
> 
> we'll need it to

move 1.0 to 1.0.0?  you don't need both right?
Filed bug 540011 for the rewrite on mozilla.com.
Attached patch patchSplinter Review
Changes the url to point to the new location
Assignee: nobody → mark.finkle
Attachment #421898 - Flags: review?(pavlov)
Attachment #421898 - Flags: review?(pavlov) → review+
pushed to default:
http://hg.mozilla.org/mobile-browser/file/a3c01b40f184
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
This is something that needs to be checked for release testing RC3
verified FIXED on build:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.1)
Gecko/20100126 Firefox/3.6.1 Fennec/1.0.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.