Last Comment Bug 539067 - random timeouts before running test_browserGlue_prefs.js and after test_browserGlue_migrate.js
: random timeouts before running test_browserGlue_prefs.js and after test_brows...
Status: RESOLVED FIXED
[fixed-in-places]
: intermittent-failure
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: x86 Windows Server 2003
: -- normal (vote)
: ---
Assigned To: Marco Bonardo [::mak] (Away 6-20 Aug)
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2010-01-11 13:04 PST by Marco Bonardo [::mak] (Away 6-20 Aug)
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1.0 [checked-in] (19.39 KB, patch)
2011-03-11 11:45 PST, Marco Bonardo [::mak] (Away 6-20 Aug)
sdwilsh: review+
Details | Diff | Splinter Review

Description Marco Bonardo [::mak] (Away 6-20 Aug) 2010-01-11 13:04:59 PST
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1263232440.1263239328.10833.gz

xpcshell timed out before running any check in this test.
Since for now any try to debug these failures has failed, i'm going to disable the test till we have a way to reproduce locally (record and replay env?), or a possible patch, known reason.
Comment 1 Marco Bonardo [::mak] (Away 6-20 Aug) 2010-01-11 13:15:20 PST
test disabled with http://hg.mozilla.org/mozilla-central/rev/5dca6c28cca5
Comment 2 :Ehsan Akhgari 2010-03-15 07:56:13 PDT
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1268658320.1268660094.11279.gz
OS X 10.5.2 mozilla-central debug test xpcshell on 2010/03/15 06:05:20
Comment 3 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-03-11 11:45:50 PST
Created attachment 518776 [details] [diff] [review]
patch v1.0 [checked-in]

this cleanups and re-enables test_browserGlue_prefs.js.
The nsBrowserGlue.js change requires proper review, but it's a piece of code used only by tests.
Comment 4 Shawn Wilsher :sdwilsh 2011-03-14 13:01:19 PDT
Comment on attachment 518776 [details] [diff] [review]
patch v1.0 [checked-in]

r=sdwilsh
Comment 5 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-04-12 19:19:25 PDT
Comment on attachment 518776 [details] [diff] [review]
patch v1.0 [checked-in]

http://hg.mozilla.org/projects/places/rev/ed6603e814a7

waiting results before bugs updated.
Comment 6 Marco Bonardo [::mak] (Away 6-20 Aug) 2011-04-18 06:06:52 PDT
http://hg.mozilla.org/mozilla-central/rev/ed6603e814a7

Note You need to log in before you can comment on or make changes to this bug.