Closed Bug 539102 Opened 10 years ago Closed 10 years ago

Entering "(" or "&" moves formfill to elements

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
ARM
Maemo
defect
Not set

Tracking

(fennec1.0+)

VERIFIED FIXED
fennec1.0
Tracking Status
fennec 1.0+ ---

People

(Reporter: aakashd, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2pre) Gecko/20100111 Firefox/3.6pre Fennec/1.1a1pre

Steps to Reproduce:
1. Go to maps.google.com
2. Tap on the search field to bring up formfill
3. Press fn (blue arrow) + h to enter a "("

Actual Results:
Formfill will move to the "search maps" button

Expected Results:
"(" should be entered into the field
tracking-fennec: --- → ?
OS: Linux (embedded) → All
Hardware: ARM → All
Summary: n900: Entering "(" moves formfill to the next element → Entering "(" moves formfill to the next element
Also, entering "&" moves formfill to the previous element.
Summary: Entering "(" moves formfill to the next element → Entering "(" or "&" moves formfill to elements
Duplicate of this bug: 536784
Duplicate of this bug: 540119
Duplicate of this bug: 536856
Attached patch patchSplinter Review
This patch makes the keypress handler only check event.keyCode since we are only interested in the arrow keys. It happens that event.charCode _can_ give the same value as DOM_VK_LEFT and DOM_VK_RIGHT for combinations of non-arrow keys.

Other code in Mozilla that tests for arrow keys only uses event.keyCode to do the check.

tested on desktop and N900. '(' and '&' work as expected. Arrows keys do move the focus between controls.
Assignee: 21 → mark.finkle
Attachment #421981 - Flags: review?(pavlov)
Attachment #421981 - Flags: review?(pavlov) → review+
tracking-fennec: ? → 1.0+
pushed to default:
http://hg.mozilla.org/mobile-browser/rev/ac41a659c3ea
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → RC
js version of snav suffer the same problem in the past:  bug 471229
verified FIXED on builds:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2pre) Gecko/20100119 Firefox/3.6pre Fennec/1.1a1pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20100119 Firefox/3.7a1pre Fennec/1.1a1pre
Status: RESOLVED → VERIFIED
Component: Linux/Maemo → General
OS: All → Linux (embedded)
QA Contact: maemo-linux → general
Hardware: All → ARM
You need to log in before you can comment on or make changes to this bug.