Bug 539103 (Springy)

Placing Bookmark Toolbar in address bar problems with viewing

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
minor
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: Richard Tan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

Hi, because of the limit on vertical space on modern day computer (16:9) I have decided to get rid of the bookmark tool bar and move the Bookmark Tool bar items folder to the address bar.

But when you open up firefox you get two arrows like the below link
http://img137.imageshack.us/img137/194/27582250.png

In order to solve this you need to right click and click on customize
http://img245.imageshack.us/img245/6808/65845610.png

And then press ok and then it works and you get the below
http://img246.imageshack.us/img246/1948/26138382.png

Noticed now that it reads bookmarks now. Is there a way to make it always read bookmarks instead of doing the thing that I was doing. It is becoming a pain and it is not theme related as all the themes work in the same way.

Reproducible: Always

Steps to Reproduce:
1. Place the bookmark tool bar items in the address bar
2. Restart Firefox
3. The folder has a double arrow icon ">>"
4. Right Click Customize
5. Press OK
6. ">>" disappears and replaced with Bookmarks.
Actual Results:  
It is explained above I think

Expected Results:  
It should not have the ">>" to start off with.

Nothing much, the URL images attach should be ok for you to follow.
(Reporter)

Updated

8 years ago
Alias: Springy
Summary: Placing Bookmark Toolbar in address bar programs with viewing → Placing Bookmark Toolbar in address bar problems with viewing
Does this happen with the default theme?
You can work around the problem with this add-on:
https://addons.mozilla.org/en-US/firefox/addon/11325

Once 3.6 comes out a couple/three weeks or so, you can ditch the add-on as its been fixed in 3.6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
(Reporter)

Comment 3

8 years ago
Erm this has not been fixed in FF 3.6
It has actually gotten worse. The work around in 3.5 doesn't work anymore and now there is no bookmark folder. Instead you get a lot of white spaces Plus the >> on it.

Please sort this out. I don't think it is a duplicate bug because it has not been fixed. Happens on all themes...

Thanks
Richard
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
please check if this happens in a new profile, if you can't reproduce in a new profile than the issue was correctly the one pointed out in comment 2, and your remaining issue is due to the theme or extensions you use (that means should be fixed by that specific theme or extension).

Otherwise, please post steps to reproduce this bug in the NEW profile.
btw, i just tested this with Firefox 3.6, and it WFM. So please double check your steps from comment 0.
This also WFM on WinXP SP3 with Firefox 3.6, and the latest m-c trunk build.

Re-closing this bug since there has been no further comment from poster in comment #3

If it does not work with 'other' themes other than default, then the themes author will need to fix the theme.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 447571
(Reporter)

Comment 7

8 years ago
Wow guys... so quick to take it of the list. Sorry been busy with work. Anyway here is the problem. Ok you can tell it is FF3.6 because of the skin feature which is cool.

http://img196.imageshack.us/img196/5918/81362302.png

The above screenshot shows what we are doing. There are 2 bookmark folder. Bookmarks and Bookmarks2. Bookmarks also have sub folders. They are both on the bookmark tool bar thingy.

http://img195.imageshack.us/img195/8665/15876807.png

The above screenshot shows this sitting nicely in the tool bar as it was designed to be. All good so far.

http://img191.imageshack.us/img191/5300/67054039.png

The above shows me moving the bookmark tool bar items to the top of the screen.

http://img141.imageshack.us/img141/4051/37838303.png

Now as you can see, Bookmark is there but Bookmark2 has disappear and now has the >> arrows again. This happens even when close or when you go back to customise and ok it which was a temporary fix in 3.5. But thats not the worse of it. When you move the Bookmark tool bar items back to the tool bard underneath you get this.

http://img141.imageshack.us/img141/3973/35360887.png

As you can see that now Bookmark2 has disappear and turned invisible and the only way to get it back up is to drag Bookmark2 into bookmark1 and then back out again. It is a weird error.

NOTE: This does not happen on some FF. I have FF3.6 running on 5 computers, 2 of which are affect but the other 3 are working. Now that is strange for me as all 5 browsers has the same themes, add on etc. I am kinda a control freak when it comes to standardisatio between all my browsers.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

8 years ago
Whoops, the last two pictures are the wrong way around. Please be aware when reading. Sorry about that....
(In reply to comment #7)
> NOTE: This does not happen on some FF. I have FF3.6 running on 5 computers, 2
> of which are affect but the other 3 are working. Now that is strange for me as
> all 5 browsers has the same themes, add on etc. I am kinda a control freak when
> it comes to standardisatio between all my browsers.

This still makes me think that's a problem of your profile. is this test you did in a NEW profile as i asked in comment 4?
Could be you did some change to userchrome.css?
(Reporter)

Comment 10

8 years ago
erm nope didnt try in a new profile. How do i do that?

Also I have not done anything in userchrome.css and it affects all themes I have.
Check http://support.mozilla.com/kb/Managing+profiles

Notice we can only guarantee functionality in the default theme.
(Reporter)

Comment 12

8 years ago
ok, I will try the following out soon and get back to you guys. Might not be tonight. I am at work now... hopefully I can do it later today.

But thanks for the help so far.
(Reporter)

Comment 13

8 years ago
Hey.. profile didn't work

But I reinstalled FF and it works now.. LOL..

Thanks everyone
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
OK, INVALID, since no patch was checked in it can't be fixed.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.