If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

operation can’t be completed because the item “libsmime3.dylib” is in use.

RESOLVED WORKSFORME

Status

()

Firefox
Installer
--
major
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Johnny Kent, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.21.8 (KHTML, like Gecko) Version/4.0.4 Safari/531.21.10
Build Identifier: 

downloaded the latest rc after email advice of availability.
When tried to drag to the applications folder in the install window it kept giving the error message:
"The operation can’t be completed because the item “libsmime3.dylib” is in use."
Rebooted the mac and with no apps open tried over and same error message.
the previous rc 3.5.7 will no longer open after this so I am stuck for now using safari.
I will wait for advice before messing further with it in case there's something that needs saving.

Reproducible: Always

Steps to Reproduce:
1.download 36 rc
2.drag ff icon over to app folder
3.
Actual Results:  
error message occurrs

Expected Results:  
ff installs
(Reporter)

Comment 1

8 years ago
Here's the error when I try to start ff after the failed install:
Firefox quit unexpectedly. Details:

Process:         firefox-bin [286]
Path:            /Applications/Firefox.app/Contents/MacOS/firefox-bin
Identifier:      org.mozilla.firefox
Version:         ??? (???)
Code Type:       X86 (Native)
Parent Process:  launchd [157]

Date/Time:       2010-01-11 20:49:01.761 -0800
OS Version:      Mac OS X 10.6.2 (10C540)
Report Version:  6

Interval Since Last Report:          190489 sec
Crashes Since Last Report:           5
Per-App Crashes Since Last Report:   5
Anonymous UUID:                      3321497D-33C6-4FEB-A296-F34B42872E8E

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: @executable_path/XUL
  Referenced from: /Applications/Firefox.app/Contents/MacOS/firefox-bin
  Reason: image not found

Model: MacBook2,1, BootROM MB21.00A5.B07, 2 processors, Intel Core 2 Duo, 2.16 GHz, 4 GB, SMC 1.17f0
Graphics: Intel GMA 950, GMA 950, Built-In, spdisplays_integrated_vram
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x87), Atheros 5416: 2.0.19.8
Bluetooth: Version 2.2.4f3, 2 service, 0 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Network Service: Parallels Shared Networking Adapter, Ethernet, en2
Network Service: Parallels Host-Only Networking Adapter, Ethernet, en3
Serial ATA Device: FUJITSU MHW2120BH, 111.79 GB
Parallel ATA Device: HL-DT-ST DVDRW  GSA-S10N
USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8501, 0xfd400000
USB Device: Bluetooth USB Host Controller, 0x05ac  (Apple Inc.), 0x8205, 0x7d100000
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac  (Apple Inc.), 0x021a, 0x1d200000
USB Device: IR Receiver, 0x05ac  (Apple Inc.), 0x8240, 0x5d200000

Comment 2

8 years ago
i know this sounds odd, but what url did you use to download firefox?

afaik we don't send people email about updates, so i'd actually like to know who/what sent you such an email.
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> i know this sounds odd, but what url did you use to download firefox?
>
I entered the url used in the bugzilla entry form on the line that said "url used" but I don't see it above.
it was http://en-us.www.mozilla.com/en-US/firefox/all-rc.html  and the download was Firefox 3.6 RC 1.dmg
 
> afaik we don't send people email about updates, so i'd actually like to know
> who/what sent you such an email.
Marcia Knous to betatesters, macqa, vistaqa, communityqateam
Subject: Firefox 3.6 Release Candidate available for testing!

Comment 4

8 years ago
ah, my fault, it goes into the "URL": field at the top of the bug.

Marcia: I suspect we need to change the language. It needs to remind people to quit Firefox before dragging.

Johnny: thanks, please:
1. open the dmg again (i hope you didn't trash it yet)
2. quit firefox
3. trash the firefox.app you have in your applications folder
4. copy the firefox.app to your applications folder
5. try running firefox.app from your applications folder

if this works, then hopefully marcia can try to ensure that her future instructions are clearer.
(Reporter)

Comment 5

8 years ago
can't quit firefox as it is not running and will no longer start as mentioned previously.
had not trashed dmg so deleted existing ff and copied new version over,
ff started ok

I must point out that when I initially tried the new install, as I have done numerous times on other previous version installs, there _was_ a warning (as usual) when I tried to copy over the app about closing FF before doing it. I then closed FF, tried the copy over and then the error occurred.
The installer trashed some part of the existing installation which it has never done to me before.  I personally think the instructions are fine and that there is a bug in the installer. YMMV. In the software environment I work in the installer should not trash an existing install even if  the previous version was not closed and the instruction to close the app before continuing should have been enough. But that's just my opinion, you wonderful people have to do the work so you get to cal the shots.
Thanks.
Created attachment 421955 [details]
Screenshot of issue

Here is a quick screenshot I took when installing the RC2 candidate - reporter is this what you saw?
(Reporter)

Comment 7

8 years ago
That is not the error I saw. The error I saw is as reported way above when opening this bug which at the time was for RC1.
After following timeless advice and deleting firefox from the apps folder before install I can no longer reproduce the problem. I reverted back as far as Firefox 3.6 Beta 1 then updated to Firefox 3.6 Beta 3 then to Firefox 3.6 Beta 5 then back to 3.5.7 which is where I think this problem started and then finally to 3.6 RC1 but on each install, though I did not close FF first I always received the usual warnings:
1. an older item named firefox exists in this location do you want to replace it with the one you are moving
2.  The operation can't be completed because firefox is in use. And
3. The operation can't be completed because a required item is in use.

Then for each install closed firefox and dragged the ff icon into the applications icon and the install worked correctly as expected. No fault found.

Although previously this bug was reproducible it is now gone, even with backtracking. I guess something was corrupted. 

I did find that someone had the exact same error back in Sept 2009 reported on the forums for an earlier version http://support.mozilla.com/de/forum/1/376813

Since I can no longer reproduce the bug I am going to mark this resolved so we don't waste any more time chasing ghosts. If it is real someone else will notice it and confirm but for now it is gone as far as I am concerned.
Thanks everyone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME

Comment 8

8 years ago
johnny: we don't really have an 'installer', when you drag the firefox icon on osx, you're performing a traditional "folder" copy. A folder copy can cause all sorts of exciting problems. Especially because we assume that you'd never do such a thing on OS X, where we like to think of .app's as a single file.
You need to log in before you can comment on or make changes to this bug.