Simple search broken when searching for open or closed bugs only

RESOLVED FIXED in Bugzilla 3.6

Status

()

--
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: juhanpel, Assigned: LpSolit)

Tracking

({regression})

3.5.2
Bugzilla 3.6
regression
Bug Flags:
approval +
blocking3.6 +

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6 (.NET CLR 3.5.30729)
Build Identifier: 3.5.2+

In the development snapshot in Landfill
When doing a simple search for open defects no defects are shown.
Reason for that is likely because the 'Status' as shown in the results has "__open__" instead of the open status values.

    * Status:  __open__
    * Product: Ѕpїdєr Séçretíøns
    * Content: spider

While in the pre-release branch installation (version 3.4.4+)

    * Status:  UNCONFIRMED, NEW, ASSIGNED, REOPENED
    * Product: Spider Séçretíøns
    * Content: spider


Reproducible: Always

Steps to Reproduce:
1. go to http://landfill.bugzilla.org/
2. go to one of the bleeding edge installations (detected in v. 3.5.2+)
3. do a simple search where
   Status=Open
   Product=Spider Séçretíøns
   Words=spider
4. check the "status" value shown on the results page.
5. If you want to see that defects should exists, do the search with status 'any'and check the statuses.
Actual Results:  
Zarro Boogs found.

Expected Results:  
List of defects.

I checked both postgres and mysql installation in landfill bleeding edged demo installations - both had the same issue.

NOTE: I do not have my own installation setup yet, so I can't check if this is a code issue or caused by current status of landfill environment only.
(Assignee)

Comment 1

9 years ago
I confirm that Bugzilla 3.5.2+ is totally broken for simple searches. If you select Open, you get Status:  __open__. If you select Closed, you get Status:  Bugzilla::Status=HASH(0xb707708), Bugzilla::Status=HASH(0xb6f9460), Bugzilla::Status=HASH(0xb6f93d0), Bugzilla::Status=HASH(0xb6f93c4), Bugzilla::Status=HASH(0xb6f9568), Bugzilla::Status=HASH(0xb709914), Bugzilla::Status=HASH(0xb6f9220).

Bugzilla 3.4.4 and older are not affected. Thanks for catching that, Juhani! :)
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking3.6+
Keywords: regression
OS: Windows XP → All
Hardware: x86 → All
Target Milestone: --- → Bugzilla 3.6
Version: unspecified → 3.5.2
(Assignee)

Updated

9 years ago
Summary: simple search does not work when searching for open defects → Simple search broken when searching for open or closed bugs only
(Assignee)

Comment 2

9 years ago
Created attachment 421259 [details] [diff] [review]
patch, v1

Arghh, my fault. I broke this in bug 535309.
Assignee: query-and-buglist → LpSolit
Status: NEW → ASSIGNED
Attachment #421259 - Flags: review?(ghendricks)
(Assignee)

Updated

9 years ago
Depends on: 535309

Updated

9 years ago
Attachment #421259 - Flags: review?(ghendricks) → review+
(Assignee)

Updated

9 years ago
Flags: approval+
(Assignee)

Comment 3

9 years ago
Checking in Bugzilla/Search.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Search.pm,v  <--  Search.pm
new revision: 1.180; previous revision: 1.179
done
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.