If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Lots of checkerboarding on zoom out after panning

RESOLVED FIXED

Status

Fennec Graveyard
Panning/Zooming
--
major
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Fennec 1.1
ARM
Maemo

Details

(Reporter)

Description

8 years ago
Build Id:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2pre) Gecko/20100112 Firefox/3.6pre Fennec/1.1a1pre

Steps to Reproduce:
1. Go to www.slashdot.org
2. After page is loaded, pan down to the bottom of the page
3. Wait for the tiles to paint and double tap on the "comments" text at the bottom of the last entry
4. Double tap to zoom out

Actual Results:
Most of the page is checkerboard-ed except for the previously zoomed-in portion of the page

Expected Results:
Since the tiles were already painted before zooming-in, I would expect those tiles to still be painted rather than having to re-paint them.
(Reporter)

Comment 1

8 years ago
The same thing can be seen while zooming in/out on the flash snippets on www.fandango.com
(Reporter)

Comment 2

8 years ago
This is working for me on build:
Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2pre) Gecko/20100124 Namoroka/3.6pre Fennec/1.0pre


This was fixed by the patches in https://bugzilla.mozilla.org/show_bug.cgi?id=538669 and/or https://bugzilla.mozilla.org/show_bug.cgi?id=539062
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

8 years ago
Component: General → Panning/Zooming
(Assignee)

Updated

4 years ago
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.