Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 526598
9 years ago
9 years ago

People

(Reporter: Donna, Unassigned)

Tracking

1.9.1 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7

I was using Vista-Aero and had no problem with the theme and when I restarted my computer the theme was no longer there and when I tried to reinstall the theme I got the error message 203. Did the necessary steps to delete the 3 files that where in the profile file and this did not correct the problem. I still cannot install any type of theme.

Reproducible: Always

Updated

9 years ago
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: theme → add-ons.manager
Version: unspecified → 1.9.1 Branch
Please enable extensions.logging.enabled and try installing again and then copy any new messages from the error console into this bug report.
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Please enable extensions.logging.enabled and try installing again and then copy
> any new messages from the error console into this bug report.

How do I enable the extension logging?
Type about:config into the url bar, look for extensions.logging.enabled in the list and double click it.
(Reporter)

Comment 4

9 years ago
I did this an this was what is listed under the errors: Error: Permission denied for <http://widgets.espn.go.com> to call method Location.toString on <http://www.google.com>.

Theme would not install. I don't know why the theme I had quit working and I have never had a problem installing themes unless they were not compatible with the current version of Firefox.
I forgot, also enable javascript.options.showInConsole and try this again. Clear the error console before trying the install so we can be sure and only get errors relating to the install attempt.
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)
> I forgot, also enable javascript.options.showInConsole and try this again.
> Clear the error console before trying the install so we can be sure and only
> get errors relating to the install attempt.

Did this and theme would still not install. Still getting error code 203 and this is what was in the error console: Error: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIZipReader.extract]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox/components/nsExtensionManager.js :: extractThemeFiles :: line 1706"  data: no]
Source File: file:///C:/Program%20Files%20(x86)/Mozilla%20Firefox/components/nsExtensionManager.js
Line: 1706
Do you have any anti-virus software installed and if so do theme installs work if you disable them?
(Reporter)

Comment 8

9 years ago
Dave

I do have antivirus and I disabled it and reinstalled the theme. It installed this time and no error messages. I have never had to disable my firewall/antivirus to install firefox themes, however, something in the antivirus must have changed today. I never thought about disabling it to reinstall the theme as this never was an issue. What has puzzled me is that this theme was already installed and I have used it for a long time and just today, it was not there anymore and only showed the default theme.

Sorry for taking so much of your time and I appreciate your help!

Thanks
This is probably resolved by bug 526598 and you should see that you don't need to disable your AV tool in Firefox 3.6.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 526598
You need to log in before you can comment on or make changes to this bug.