Closed Bug 539375 Opened 15 years ago Closed 14 years ago

Right clicking on Firefox.exe and selecting Pin to Taskbar does nothing.


(Firefox :: Shell Integration, defect)

Windows 7
Not set





(Reporter: geeknik, Unassigned)



If you don't have a Minefield icon pinned to your taskbar and you go to C:\Program Files (x86)\Minefield and you right click on Firefox.exe and select Pin to Taskbar, nothing appears on your taskbar. If you right click on Firefox.exe again, you will see Unpin from Taskbar instead, even though there is nothing on the taskbar. The only way I can get a Minefield icon pinned to my taskbar is to drag the Firefox.exe to the taskbar or select the Pin to Taskbar option from a shortcut on my desktop.
Component: Installer → Shell Integration
QA Contact: installer → shell.integration
Same here with:

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a4pre) Gecko/20100402 Minefield/3.7a4pre (.NET CLR 3.5.30729)
I've just found what was wrong.
I've changed the installation directory of the Minefield and that was it.
I unpack "" again and everything was OK now.

So, no more bugs here!
Blocks: win7support
Brian are you still having issues with this or has it been fixed by bug 521141?
It mostly works now, it pins the icon to the taskbar when I right click on Firefox.exe in C:\Program Files (x86)\Minefield\, however, when I click on the icon, it isn't grouping correctly.

This is with the latest nightly build, 20100602040404 built from
Try opening the jumplist for each taskbar icon and right clicking on the _Minefield_ option and open properties.  Do both icons point to the same target file? 

Also have you tried removing all shortcut icons from your windows first? I think the AppID change worked better with a clean set of icons.

The only other thing I know about here is the options to customize and only combine when the windows 7 taskbar is full might do this.
I'm not having much luck reproducing this. Unpin all taskbar shortcuts -> Right-click exe -> pin then click on the pinned shortcut, minefield launches and it's grouped correctly. Double clicking on the exe groups correctly as well.
Closing since this is no longer an issue.
Closed: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.