Main menu remains disabled after exiting "Customize Toolbars" dialog.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: roberto.neagu, Unassigned)

Tracking

3.6 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

BOTH Main menu AND "Customize..." option of the toolbar context menu are disabled after exiting the "Customize Toolbars" dialog.  This happens with 3.6 RC 1 on both Linux (SuSE 11/WindowMaker) and Windows (XP).
FFox 3.5.6 on Linux: only "Customize..." option is disabled after closing the dialog, the main menu is re-enabled and works.
FFox 3.5.7 on Windows is not affected.

Reproducible: Always

Steps to Reproduce:
1. Right click the menu bar.
2. Select "Customize..." from context menu.  "Customize Toolbars" opens and main menu is disabled.
3. Close the dialog. -> the main menu remains disabled (3.6 RC 1).
4. Right click again on a toolbar -> "Customize..." is disabled.
Actual Results:  
After closing the dialog (either by pressing "Done" or window's close button) 
 - the main menu remains disabled.  This happens with ffox 3.6 RC1 on both Linux and windows, while 3.5.6 under Linux and 3.5.7 under Windows are not affected.
 - "Customize" option of the toolbar context menu is disabled. ffox 3.6 RC1 (linux/wind) and 3.5.6 (linux) are affected, 3.5.7 (windows) is not.

Expected Results:  
Main menu should be active.
"Customize..." entry of toolbar's context menu should be active.

The bug happens with any theme, including the default one.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.6 Branch

Comment 1

8 years ago
I can't reproduce this with current Firefox.  Both the menu bar and the customize option in the context menu become re-enabled after closing the customize dialog.

Can you still reproduce this?

Comment 2

8 years ago
No response in 3 months; closing.  Please feel free to comment here if you still observe the bug, and someone can reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.