Indexing prevents Thunderbird from checking for new mail with message "This folder is being processed..."

RESOLVED DUPLICATE of bug 392680

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 392680
8 years ago
7 years ago

People

(Reporter: zed, Unassigned)

Tracking

Trunk
Other
Windows 2000

Firefox Tracking Flags

(blocking-thunderbird3.1 -)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Created attachment 421432 [details]
Screengrab of error message

Version: Latest nightly, 3.0x, Win32.

If indexing is occurring when an attempt is made to check for new mail, Thunderbird generates an error informing the user that (s)he should wait until the indexing is complete before attempting to check mail.

I've been reliably informed that this shouldn't be happening (hello dmose!) and therefore I'm reporting here.. screengrab of error message attached.

Both pop3 and imap accounts are configured in the profile, and the error is easily reproduced here.
Flags: blocking-thunderbird3.1?

Updated

8 years ago
Component: General → Backend
OS: Windows XP → Windows 2000
Product: Thunderbird → MailNews Core
QA Contact: general → backend
Summary: Indexing prevents Thunderbird from checking for new mail → Indexing prevents Thunderbird from checking for new mail with message "This folder is being processed..."

Comment 1

8 years ago
I'm quite certain I read an older bug this morning that describes the same problem

zed, platform=other ... why?
Whiteboard: dupme

Comment 2

8 years ago
Indexing does not lock the folder or touch the pop3 server. Indexing may slow things down enough that multiple checks for new mail run - what's your check for new mail interval?

This message is specific to pop3 folders/servers. It is displayed if we're busy doing something with the pop3 server. The message you attached doesn't say anything about indexing. Does this happen on startup, or once you're up and running? Is it happening when your machine comes out of hibernation?

Comment 3

8 years ago
compact in the background could also cause this
We can't hold a release on a bug until we have clear steps to reproduce and reason to believe that it effects more than a few people.  Feel free to renominate if/when those things become clear/true.
blocking-thunderbird3.1: --- → -
Flags: blocking-thunderbird3.1?

Comment 5

8 years ago
"indexing" can't cause this unless there's a conflict on a thread. So I think it's a coincidence, and that the main issue here is bug 392680, or one of the bugs in the query of bug 392680 comment 12.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 392680
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved
Duplicate!
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.