ASSERTION: Mouse move must have some target content. file: content/events/src/nsEventStateManager.cpp

RESOLVED FIXED

Status

()

Core
DOM: Events
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: hsivonen, Assigned: hsivonen)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Steps to reproduce:

1) Load https://bugzilla.mozilla.org/attachment.cgi?id=387222 (with or without html5.enable) in a debug build.

Actual results:
The assertion at http://mxr-test.konigsberg.mozilla.org/mozilla-central/source/content/events/src/nsEventStateManager.cpp#3565 fires.

Expected results:
No assertion.

Comment 1

8 years ago
Ok, that assertion shouldn't be an assertion, probably not even a warning.
(Assignee)

Comment 2

8 years ago
Created attachment 421618 [details] [diff] [review]
Remove the assertion
Assignee: nobody → hsivonen
Status: NEW → ASSIGNED
Attachment #421618 - Flags: review?(Olli.Pettay)

Comment 3

8 years ago
Comment on attachment 421618 [details] [diff] [review]
Remove the assertion

Yeah.

Need to change ESM at some point to handle document object as target, but there is no need to assert anything, since there is nothing bad happening.
Attachment #421618 - Flags: review?(Olli.Pettay) → review+
(Assignee)

Comment 4

8 years ago
Thanks.

http://hg.mozilla.org/mozilla-central/rev/95b290937988
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.