Closed Bug 53944 Opened 22 years ago Closed 20 years ago

bgcolor of body overrides bgcolor or tr in html output

Categories

(Core :: XSLT, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla1.0.1

People

(Reporter: jjs, Assigned: peterv)

References

Details

(Keywords: testcase)

Attachments

(4 files, 1 obsolete file)

The bgcolor of <tr> elements are ignored for their children <td> when a bgcolor
for <body> is set. This only seems to effect transformed documents, since using
a transformed document save as xhtml colours as expected.
This can be worked around by specifiy the bgcolor of the <td> themselves.

To me it would appear to be a contentsink problem when we dynamically create the
output document. So I think we need a someone with alot more knowledge of this area.

Attaching a test xsl and xml file.
Attached file Test xml file (obsolete) —
The above test case should show a single table row of a single colour with the
letter C in it.
Keywords: testcase
setting bug status to New
Status: UNCONFIRMED → NEW
Ever confirmed: true
Jus, could you attach an xhtml file that works? I can't get it to work in a 
regular xhtml file, the C always has a white background.
Status: NEW → ASSIGNED
Is this an XSLT bug...it doesn't sound like it. Is it not producing the correct 
result document?

First of all, I see a difference in the display, so the test case is allright.
At least on unix, if this is different on Mac, then HOOPS.
And it looks like it's a problem of our handling the html output.
When loading the html (already processed) file, I get a
Enabling Quirk StyleSheet
Disabling Quirk StyleSheet
(after setting the DOCTYPE to strict), I get no such messages when loading
the xml. I haven't managed to generate a strictly xhtml file, somebody?
So this looks like a problem of transformiix talking to the style system

Axel
The workaround for now is to wrap your tr's in a tbody. I'll see if we get some
movement on bug 68061. We will porbably need to do some work ourselves anyhow.
Assignee: kvisco → peterv
Status: ASSIGNED → NEW
OS: Windows 2000 → All
Hardware: PC → All
Target Milestone: --- → mozilla1.0
Depends on: 96647
*** Bug 86664 has been marked as a duplicate of this bug. ***
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
For the ease of use, let's get the other stylesheet for one-click QA, too
Attachment #15398 - Attachment is obsolete: true
Fixed by the patch for bug 96647.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
actually, this has only been fixed for html-output (by design, we'd be violating
the specs otherwise). The xhtml problem is covered by bug 68061
Status: RESOLVED → VERIFIED
Summary: bgcolor of body overrides bgcolor or tr in xhtml output → bgcolor of body overrides bgcolor or tr in html output
You need to log in before you can comment on or make changes to this bug.