Upgrade from 3.5.7 (any 3.5 series) to 3.6 release candidate loses libjavaplugin

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: frush, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

We have a stable config using /usr/lib/jvm/jre-1.6.0-sun/plugin/i386/ns7/libjavaplugin_oji.so* (linked to /usr/lib/mozilla/plugins)  and Firefox 3.5.*.  Java plugin loads and is shown in about:plugins, and java tests work.

Replacing Firefox with 3.6RC1 the java plugin simply does not load.  It fails to appear in about:plugins, and java pages complain about missing plugin.

I suspect this bug is related to earlier bugs reported about java plugin simply crashing Firefox, so someone may have turned off loading this plugin to get the 3.6RC1 released.

Reproducible: Always

Steps to Reproduce:
1.Start with working config using 3.5.7 and properly installed sun java plugin.
1.5  check about:plugins,   Java plugin shows up.
2.upgrade firefox to 3.6
3.check about:plugins. No java plugin.
This is no bug.
The support for the old java plugin is finally dropped with FF3.6.
You need the new plugin which is a standard npapi plugin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
According to SUN, Java 1.6.0_10 (Version 6 update 10) supports npapi. (http://www.java.com/en/download/faq/firefox_newplugin.xml)

We're running the most recent version of Java, so while I agree that we need a NPAPI compliant plugin, the information I have suggests that we are using that plugin, and we're still having issues. 
 
java -version
java version "1.6.0_17"
Java(TM) SE Runtime Environment (build 1.6.0_17-b04)
Java HotSpot(TM) Server VM (build 14.3-b01, mixed mode)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
>/usr/lib/jvm/jre-1.6.0-sun/plugin/i386/ns7/libjavaplugin_oji.so* (linked to
>/usr/lib/mozilla/plugins


>According to SUN, Java 1.6.0_10 (Version 6 update 10) supports npapi.

They ship both, the new and the old plugin with 1.6 U10 AFAIK.

>the information I have suggests that we are using that plugin, and we're still having issues
The information that you provided with comment 0 suggest the opposite.
(/usr/lib/jvm/jre-1.6.0-sun/plugin/i386/ns7/libjavaplugin_oji.so : oji is the old plugin)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

9 years ago
Ahh,  I see.   Thank you for the clarification.   

The newest download from Sun doesn't seem to include any other plugin files, but I'll take my investigation there, since that seems to be the issue.

I appreciate your patience while I get my brain wrapped around this.
(Reporter)

Comment 5

9 years ago
If anyone else searches on this issue, here a cookie crumb.

The new plugin name and location for the Sun JRE might be:

/usr/lib/jvm/java-1.6.0-sun-1.6.0.17/jre/lib/i386/libnpjp2.so
Sorry that I couldn't tell you the library name of the new plugin because I'm a win32 user. I will try to remember the name for the next user :-)
You need to log in before you can comment on or make changes to this bug.