Closed Bug 539546 Opened 10 years ago Closed 7 years ago

Trigger password autofill earlier to avoid overwriting unnecessary user input

Categories

(Toolkit :: Password Manager, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 58724

People

(Reporter: limi, Unassigned)

References

(Blocks 1 open bug)

Details

Right now, the password autofill triggers late in the process of downloading a page, it seems to wait until the page has signaled that it's ready instead of doing it when the DOM is ready.

On slow connections, this means people start typing their username/password in the login box, since it doesn't seem to be filled in, and then their entry gets overwritten by the autofill mechanism.

Our goal should be to let them log in as early as possible.
Blocks: cuts-focus
OS: Mac OS X → All
Component: General → Password Manager
Product: Firefox → Toolkit
QA Contact: general → password.manager
Version: 3.6 Branch → Trunk
This problem might need some criper definition... Login manager already uses the DOMContentLoaded event to trigger filling in logins, not the Pageload event. That's the earliest (existing) mechanism I know of to hook into page processing.

Bug 355063 or bug 552827 may allow us to do processing earlier than DOMContentLoaded, if it triggers pwmgr when the form element is inserted into the DOM.

But there might still be a separate issue with making sure we don't interfere with the user typing something, no matter when the password manager twiddles the page.
Changing bug title, since current one is technically incorrect.
Summary: Password autofill should trigger on DOM ready, not on page ready → Trigger password autofill earlier to avoid overwriting unnecessary user input
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 58724
You need to log in before you can comment on or make changes to this bug.