Multiple pages saved as "Home Page" in options do not open at startup

RESOLVED FIXED

Status

()

Firefox
Extension Compatibility
RESOLVED FIXED
9 years ago
4 years ago

People

(Reporter: Bill Hamilton, Unassigned)

Tracking

3.6 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caused by tab mix plus])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2) Gecko/20100105 Firefox/3.6

I had 7 pages setup as my "Home Page" in Options before upgrading to 3.6rc1. After upgrading, 3.6rc1 will only open the first two pages either at startup or when clicking the Home icon.

Reproducible: Always

Steps to Reproduce:
1. Open multiple pages in tabs
2. Open the Options under the Tools menu
3. In the General pane, click Use Current Pages
4. Click Ok
5. Restart Firefox 3.6rc1
Actual Results:  
First two pages open in separate tabs, but not the remaining pages.

Expected Results:  
Expected 7 tabs each with a separate url open.
Are those seven pages still set to open? Maybe your preferences got corrupted.
(Reporter)

Comment 2

9 years ago
In so far as I can tell, the preferences are all good. I reviewed all the tabs and preferences and I cannot see anything that isn't what had in the previous version.

I deleted all pages in the Home Page input box and then opened a tab, navigated to each page I wanted to include and came back to Preferences and reset it using "Use Current Pages". I then exited, restarted and all pages opened as expected. I'm not sure if this should be marked closed or noted as a conversion issue from 3.5 to 3.6rc1 when you have multiple pages (for confirmation before proceeding).

Comment 3

9 years ago
I'm running the 3.6 nightlies and have seen this behavior for some time.  I tried Bill Hamilton's procedure and it didn't work for me.

Comment 4

9 years ago
I have the same issue.  

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

I have 2 different computers with 3.6 on them, one has 5 tabs for the homepage, the other has 9.  When I open up Firefox for the, I get only 2 tabs.  If I click on the "Home" button, it will then load up all of the tabs correctly (in addition to the initial 2).  I have also tried what Bill mentioned, and it didn't fix my problem.

Comment 5

8 years ago
Same on my machine with final 3.6.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2) Gecko/20100115 Firefox/3.6

I had my 3 tabs set for homepage as long as firefox exists, but after upgrading 3.5 to 3.6 this bug occurs. 
When I open up Firefox for the, I get only 2 tabs.  If I click on the "Home" button, it will then load up the third tab correctly, but adds the second tab as the fourth tab.  
I have also tried what Bill mentioned, and it didn't fix my problem.
(Reporter)

Comment 6

8 years ago
The work-around I noted above is not a permanent fix. I'm still experiencing this issue and, like others, have only two tabs when I launch Firefox. I close one, then click Home to get all my pages open.

Comment 7

8 years ago
I have the same problem, but I am working on Windows XP with a 32 bit version of Firefox 3.6 final.

Could there be a conflict with some addon ? I had to "force" a few plugins to install into 3.6, and they seem to work fine, but still...
It very well could be. Chris. I would suggest going to support and asking them for help in narrowing down the issue. If it ends up being a bug in firefox (which I highly doubt), then come on back.

Comment 9

8 years ago
I just went through and disabled all of my Add-ons, and then restarted Firefox.  

All of my tabs came back up as they should.

I then re-enabled them one at a time, restarting Firefox after each was enabled.  

Even after enabling all of my Add-ons, the tabs are coming up properly.   

Weird.

Comment 10

8 years ago
Update - Tab Mix Plus 0.3.8.2 is the culprit.  I didn't re-enable that Add-on by mistake.   When I did, the problem returned.

Comment 11

8 years ago
Update 2 - The maker of Tab Mix Plus has a patch/update that resolves this issue:

http://tmp.garyr.net/forum/viewtopic.php?t=11747

http://tmp.garyr.net/forum/viewtopic.php?p=39147#39147

Comment 12

8 years ago
I confirm Mr. Kaye's comments 10 and 11 for my case as well.
Bill, do you have Tab Mix Plus installed?
Those who are seeing TMP problems, please report to the developer of Tab Mix Plus.
(Reporter)

Comment 14

8 years ago
I disabled TMP and closed/relaunched Firefox; the behavior is no longer present - it now behaves as expected. I'd recommend closing this as a plug-in conflict.
Please report to the developers of tab mix plus.
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Whiteboard: [caused by tab mix plus]
Version: unspecified → 3.6 Branch

Comment 16

4 years ago
Fixed ages ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.