Use the same is-callable test in js_obj_define{G,S}etter and PropertyDescriptor::initialize

RESOLVED DUPLICATE of bug 547046

Status

()

RESOLVED DUPLICATE of bug 547046
9 years ago
9 years ago

People

(Reporter: Waldo, Assigned: Waldo)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

9 years ago
The former use JS_TypeOfValue == JSTYPE_FUNCTION.  The latter uses js_IsCallable.  Which implementation is "right"?

In any case, having two separate ways (one more generic than the other) to do the same thing is a bad idea.  js_IsCallable should include whatever the desired code is, and it should be used universally.
(Assignee)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 547046
You need to log in before you can comment on or make changes to this bug.