Need CSS pseudoclass for crashed plugins

RESOLVED FIXED in mozilla1.9.3a2

Status

()

RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Dolske, Assigned: Dolske)

Tracking

Trunk
mozilla1.9.3a2
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(status1.9.2 .4-fixed)

Details

(Whiteboard: [fixed-lorentz])

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

9 years ago
Created attachment 421724 [details] [diff] [review]
Patch v.1

The UI we show in content for missing/blocked/disabled plugins relies on XBL + CSS pseudoclasses to show the appropriate stuff. See toolkit/mozapps/plugins/content/missingPluginBinding.css

Bug 538910 is adding UI here for when a plugin has crashed, and will need similar pseudoclass support. This was pretty easy to do my just copying what Mossop did for bug 391728.
Might be nice to add some appropriate test_parseable() calls in layout/style/test/test_selectors.html .  Otherwise looks fine to me, though bzbarsky should probably take a quick look to make sure he doesn't see anything missing.
Looks fine to me.
(Are we sure that the ContentStatesChanged notification is sent whenever we go into or out of this state?)
(Assignee)

Comment 4

9 years ago
That seems to be the problem -- bug 539851.
(Assignee)

Updated

9 years ago
Duplicate of this bug: 539851
(Assignee)

Comment 6

9 years ago
Created attachment 422446 [details] [diff] [review]
Patch v.2

Rolled in the trivial fix for bug 539851.
Attachment #421724 - Attachment is obsolete: true
Attachment #422446 - Flags: review?(dbaron)
(Assignee)

Comment 7

9 years ago
Created attachment 425564 [details] [diff] [review]
Patch v.3

Added tests.
Attachment #422446 - Attachment is obsolete: true
(Assignee)

Comment 8

9 years ago
Pushed http://hg.mozilla.org/mozilla-central/rev/939876c7428e
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.3a2
(Assignee)

Updated

9 years ago
Flags: in-testsuite+

Comment 9

9 years ago
http://hg.mozilla.org/projects/firefox-lorentz/rev/6e5f63278c8f

dbaron/bz: this was not a completely trivial backport because the table-driven CSS_STATE_PSEUDO_CLASS on trunk is not present on branch. Can you please verify that my patch is correct?
Whiteboard: [fixed-lorentz]
The lorentz patch looks good to me.
Blanket approval for Lorentz merge to mozilla-1.9.2
a=beltzner for 1.9.2.4 - please make sure to mark status1.9.2:.4-fixed
Merged into 1.9.2 at http://hg.mozilla.org/releases/mozilla-1.9.2/rev/84ba4d805430
status1.9.2: --- → .4-fixed
You need to log in before you can comment on or make changes to this bug.