Last Comment Bug 539837 - Synchronize icons for RSS folders between folder list and feed subscriptions window
: Synchronize icons for RSS folders between folder list and feed subscriptions ...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Folder and Message Lists (show other bugs)
: unspecified
: x86 Windows XP
: -- enhancement (vote)
: Thunderbird 24.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
: 533189 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-14 16:57 PST by Ed
Modified: 2013-06-25 05:17 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Image of Feed Subscriptions icons (39.22 KB, image/jpeg)
2010-01-14 16:59 PST, Ed
no flags Details
Image of folder list icons (10.59 KB, image/jpeg)
2010-01-14 17:00 PST, Ed
no flags Details
Proposal with livemark-item.png (35.56 KB, image/jpeg)
2013-05-31 02:07 PDT, Richard Marti (:Paenglab)
no flags Details
patch (2.56 KB, patch)
2013-05-31 09:06 PDT, alta88
no flags Details | Diff | Splinter Review
patch with css and icons (38.22 KB, patch)
2013-05-31 15:08 PDT, Richard Marti (:Paenglab)
no flags Details | Diff | Splinter Review
patch in action on Win7 (16.36 KB, image/png)
2013-05-31 15:10 PDT, Richard Marti (:Paenglab)
no flags Details
patch in action on OS X (4.22 KB, image/png)
2013-05-31 15:12 PDT, Richard Marti (:Paenglab)
no flags Details
patch with css and icons (44.67 KB, patch)
2013-06-02 01:57 PDT, Richard Marti (:Paenglab)
no flags Details | Diff | Splinter Review
patch in action on Win7 (18.92 KB, image/png)
2013-06-02 02:01 PDT, Richard Marti (:Paenglab)
no flags Details
patch in action on OS X (4.77 KB, image/png)
2013-06-02 02:01 PDT, Richard Marti (:Paenglab)
no flags Details
patch (45.74 KB, patch)
2013-06-02 13:59 PDT, Richard Marti (:Paenglab)
bwinton: review+
bwinton: ui‑review+
Details | Diff | Splinter Review

Description Ed 2010-01-14 16:57:32 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

Admittedly, this is somewhat of a minor annoyance, so prioritize (ignore) accordingly.

In the folder list tree view, folders are shown using the RSS icon, and any feeds themselves are not displayed.  In the feed subscriptions (from Manage Subscriptions off the account page, or right click in the folder view to choose Subscribe...), folders are shown with folder icons, and feeds are shown with RSS icons.

I find it a little peculiar to see different icons for the folders in these two places.  I recognize that the feed subscriptions probably want to show a folder icon to distinguish from RSS feeds, but that means I see the RSS icon for two distinct purposes - in one place it's a folder of RSS feed content, and in the other it's an RSS feed.  I'd suggest using a normal folder icon overlaid with a small rss feed icon - similar to how the mail account icon (an envelope) has the overlay of a little lock when the account is managed securely.  That could be used in both places, leaving the RSS icon to denote feeds.

Reproducible: Always

Steps to Reproduce:
1. If necessary, create a Blogs & News Feeds account.
2. Create a folder under that account.  Note that it uses the RSS icon.
3. Subscribe to an RSS feed and store the articles in the newly created folder.
4. Right click on the folder, and select Subscribe... to see the feed subscriptions.
5. Note that the folder in feed subscriptions shows with a normal folder icon, and the feed shows with the RSS icon (identical to the one identified in step 2).
Actual Results:  
I see a single icon (the RSS icon) representing two different entities.  In one case it represents a folder of RSS feed items, and in another it represents an RSS feed.

I see a single entity (a folder of RSS items) represented by different icons.  One is the RSS icon, and the other is a plain folder icon.

Expected Results:  
I expect to see icon consistency.
Comment 1 Ed 2010-01-14 16:59:07 PST
Created attachment 421730 [details]
Image of Feed Subscriptions icons
Comment 2 Ed 2010-01-14 17:00:00 PST
Created attachment 421731 [details]
Image of folder list icons
Comment 3 alta88 2013-05-29 11:17:47 PDT
I agree this is confusing and have seen comments (greader refugees) that indicate people don't realize a folderpane row is a folder, which can contain 0, 1, or many feed subscriptions.

Blake/Richard, I propose the icons in a feed account are changed such that a folder with 0 feed subscriptions shows a standard folder icon, and that a folder with 1 or more subscriptions be indicated with a platform specific feed-folder icon.

For windows:
http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/livemark-folder.png
For windows aero:
http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/livemark-folder-aero.png

For linux:
there isn't a feed folder icon, use the current icon (which style seems to have come from linux anyway and been applied to all platforms).

For osx:
http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/page-livemarks.png

It would be trivial to get the folder feedUrl property and emit it for styling the tree, and also reflect the same state in the subscribe dialog.

Thoughts?
Comment 4 Richard Marti (:Paenglab) 2013-05-30 02:20:12 PDT
(In reply to alta88 from comment #3)
> 
> Blake/Richard, I propose the icons in a feed account are changed such that a
> folder with 0 feed subscriptions shows a standard folder icon, and that a
> folder with 1 or more subscriptions be indicated with a platform specific
> feed-folder icon.
> 
> Thoughts?

I agree with the folder with 0 feed. Here it makes sense to show the standard folder icon.
With 1 or more feeds I think it's better to leave it like it is. The Inbox, Sent, Trash etc. are folders and have also their special icon.
The folder with subscriptions can be considered as one feed no matter if it has 1 or more subscriptions (all subscriptions are mixed in the same folder), so the feed icon makes sense for me.
Comment 5 alta88 2013-05-30 06:58:42 PDT
But that still leaves the crux of the problem, that folderpane and subscribe dialog are quite different though represent the same structure.

Alternatively, the subscribe dialog folder should be the feed icon and the url should be this icon (same on all platforms).  (Of course, the best solution would be the feed's favicon.)
http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/places/livemark-item.png

The feed folder icons work better to represent 'container', imo.  But regardless, the icon is overbearing compared to others in folderpane, perhaps giving it a 14x14 size helps reduce that?

At some point the actual feed url could be represented in folderpane (bug 308434) as in subscribe.  This would allow feed url state display/feedback, for which there are several bugs and which would really take feeds in Tb to the next level.
Comment 6 Richard Marti (:Paenglab) 2013-05-31 02:07:26 PDT
Created attachment 756452 [details]
Proposal with livemark-item.png

(In reply to alta88 from comment #5)
> Alternatively, the subscribe dialog folder should be the feed icon and the
> url should be this icon (same on all platforms).  (Of course, the best
> solution would be the feed's favicon.)
> http://mxr.mozilla.org/mozilla-central/source/browser/themes/osx/places/
> livemark-item.png

I think this is a good solution. I've attached a rough proposal with using livemark-item.png

> But regardless, the icon is overbearing compared to others in folderpane,
> perhaps giving it a 14x14 size helps reduce that?

I agree, if we would use the livemark-item.png instead it would also look lighter.
Comment 7 alta88 2013-05-31 06:10:43 PDT
That looks good, and it looks like it works cross platform, although I can't find where you got the borderless orange icon for urls..  Anyway, can you do the css patch?  I can add the feedless folder code in a separate patch.
Comment 8 Richard Marti (:Paenglab) 2013-05-31 06:32:13 PDT
I created the borderless orange icon quickly because I thought the gray one would not be good visible on XP systems with gray highlight bar.

I'll create the css patch and attach it here.
Comment 9 alta88 2013-05-31 09:06:05 PDT
Created attachment 756599 [details] [diff] [review]
patch


This will emit (in addition to folderNameCol) properties of
isFeedFolder-true (for folder with feeds)
isFeed-true (for feed url)

so serverType-rss should be replaced unless it really is an account folder.
Comment 10 Richard Marti (:Paenglab) 2013-05-31 15:08:27 PDT
Created attachment 756810 [details] [diff] [review]
patch with css and icons
Comment 11 Richard Marti (:Paenglab) 2013-05-31 15:10:55 PDT
Created attachment 756813 [details]
patch in action on Win7

Alta88, would it be possible to give the folder without subscription in folderpane also the default folder icon?
Comment 12 Richard Marti (:Paenglab) 2013-05-31 15:12:26 PDT
Created attachment 756815 [details]
patch in action on OS X

I don't add a screenshot of Linus as this looks like Win7.
Comment 13 alta88 2013-06-01 07:01:02 PDT
(In reply to Richard Marti [:Paenglab] from comment #11)
> Created attachment 756813 [details]
> patch in action on Win7
> 
> Alta88, would it be possible to give the folder without subscription in
> folderpane also the default folder icon?

The css rules for trees should be in folderPane.css, and specifically not in feed-subscriptions.css.  The dialog uses folderPane.css already.  The problem is due to an overriding rule in folderPane.css, which is what I was referring to above..

Otherwise, looks great.  One thing, would it be appropriate to have the feed icon have a transparent background/no border?  In a favicon style.  One day I may implement favicons.
Comment 14 Richard Marti (:Paenglab) 2013-06-02 01:57:34 PDT
Created attachment 757088 [details] [diff] [review]
patch with css and icons

Sorry, my bad. I exchanged now the serverType-rss selector with isFeedFolder-true in foldePane.css and it works.
But now in search dialog's menulist the feeds have no feed icon. It looks like this tree checks only for serverType-rss. I could add a rule like .foldersTree > treechildren::-moz-tree-image(folderNameCol, serverType-rss) to only use the serverType-rss in this tree but then I need also .foldersTree > treechildren::-moz-tree-image(folderNameCol, isServer-true, serverType-rss) to give the server his icon back.

Please can you check, why the tree in search dialog doesn't check isFeedFolder-true?

The rule for isFeed-true is still in feed-subscriptions.css because this is only used there and needs only to be loaded when this dialog is open.
Comment 15 Richard Marti (:Paenglab) 2013-06-02 02:01:13 PDT
Created attachment 757089 [details]
patch in action on Win7

I gave the  isFeed-true icon a light gray border to distinguish to the normal feed.
Comment 16 Richard Marti (:Paenglab) 2013-06-02 02:01:40 PDT
Created attachment 757090 [details]
patch in action on OS X
Comment 17 alta88 2013-06-02 09:00:31 PDT
The menulist tree classes are set using an old binding, here:
http://mxr.mozilla.org/comm-central/source/mail/base/content/mailWidgets.xml#2369
Rather than muck with that binding and rdf based templates, the rule that would work is to first set 'serverType-rss' to the feed-folder icon (which will by far be most common), then immediately after set 'serverType-rss isServer' to the account icon.

Now, this rdf based properties setting won't easily allow for feedFolder-true to handle the empty folder case in the menupopup.  I suggest we do that as a followup; in any case it just remains as it is now.

The solution will be to convert the search folderpicker menupopup to the newer binding, which is used by the folder location widget and Subscribe already; it seems like the search dialog picker was forgotten.  It's here:
http://mxr.mozilla.org/comm-central/source/mailnews/base/content/folderWidgets.xml#13

I really think the feed url icon looks even more like the folder icon now..  So to make it differentiated, I still think borderless and transparent bg would be better and also would be lighter/cleaner.
Comment 18 alta88 2013-06-02 09:12:56 PDT
Also, since you have the main patch ;), the subscribe dialog function should not affect seamonkey, and thus should be:

     getCellProperties: function (aRow, aColumn) {
       let item = this.getItemAtIndex(aRow);
       let folder = item && item.folder ? item.folder : null;
#ifdef MOZ_THUNDERBIRD
       let properties = ["folderNameCol"];
       let hasFeeds = folder ? FeedUtils.getFeedUrlsInFolder(folder) : false;
       let prop = !folder ? "isFeed-true" :
                  hasFeeds ? "isFeedFolder-true" :
                  folder.isServer ? "serverType-rss isServer-true" : null;
       if (prop)
         properties.push(prop);
       return properties.join(" ");
#else
       return !folder ? "serverType-rss" :
              folder.isServer ? "serverType-rss isServer-true" : "livemark";
#endif
     },
Comment 19 Richard Marti (:Paenglab) 2013-06-02 13:59:27 PDT
Created attachment 757176 [details] [diff] [review]
patch
Comment 20 alta88 2013-06-12 19:46:58 PDT
*** Bug 533189 has been marked as a duplicate of this bug. ***
Comment 21 Blake Winton (:bwinton) (:☕️) 2013-06-16 18:28:52 PDT
Comment on attachment 757176 [details] [diff] [review]
patch

Yeah, I like the way this looks, and it makes sense.  ui-r=me.

And I couldn't find any problems with the code, so r=me, too.
Comment 22 Ryan VanderMeulen [:RyanVM] 2013-06-18 08:26:42 PDT
https://hg.mozilla.org/comm-central/rev/23f007e3461d

Note You need to log in before you can comment on or make changes to this bug.