If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Need explanation of IDLE functions

RESOLVED DUPLICATE of bug 449021

Status

Thunderbird
Account Manager
RESOLVED DUPLICATE of bug 449021
8 years ago
6 years ago

People

(Reporter: Ness Blackbird, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091204 Thunderbird/3.0

This started with bug 539386, now resolved (WFM).  The problem was that I didn't know about IMAP IDLE.  The problem as I perceived it was that Thunderbird refused to NOT pick up email when set to pick up infrequently or never: once I read the mail manually, it kept picking it up due to the IDLE function.  

So I reported the bug, and learned about IDLE.  This is not the optimum way for me to learn how to use the system :)

I think the user interface should inform people looking to pick up mail on an infrequent basis about the IDLE function.  I'm not sure exactly what this should look like.  It seems the best thing would be to check whether IDLE is active whenever the "check for new messages every ___ minutes" is set above 1 minute.  If IDLE is active, warn the user that they need to turn it off, or ask them if they want it on, or something like that.


Reproducible: Always

Steps to Reproduce:
1.  Set mail reading frequency at an infrequent rate with IDLE on your mail server.
2.  Check mail.  
3.  Send mail to the account.  It will be picked up quickly rather than waiting.  

This is all "correct" but confusing.


Expected Results:  
System should inform user of the potential problem when it exists.

Comment 1

8 years ago
Not correct - even if IDLE is supported by the IMAP server, this doesn't mean that the IMAP server will notify the client every time a new mail arrives. You still need to poll the server every once in a while. IDLE just allows you to receive most email quicker, without resorting to a very small poll interval.

Suppose you have an IMAP server with 10.000 users. If you sent an email to all users at once (like what happens in a corporate environment), you absolutely do not want to notify them all at once (which is similar to all of them pressing the "get mail" button at the same time). In reality, the IMAP server will limit the number of notification to something like 10 per second. In that case, it would take 1000 seconds (17 minutes) to notify them all. Some IMAP clients might query the server faster, even without being prompted by the server, because of their poll timer (10 minutes or so), or because the user pressed the "get mail" button. An email to 10 persons will not see this, as all users can be notified immediately.

Also note that this requires that the connection will stay open. A IMAP server will probably want to limit the number of open connections - 10000 open connections like in the example above, is probably not good either.

dupe of bug 449021 ?
(Reporter)

Comment 2

8 years ago
No, not a dupe of bug 449021.  This bug is only about the user interface, which does not clarify the situation.  (bug 539386 and bug 449021 are duplicates, but this bug was "spun off" from from 539386).

Jo, I'm not sure what you're saying is "not correct".  Are you saying that the user interface of Thunderbird DOES inform the user how to get mail infrequently if they want to when IDLE is active?  I think it does not.
Jo, see comment 2.

Comment 4

6 years ago
I wrote an IMAP proxy server a long time ago, and I know about IDLE. What I tried to explain is that even if you have IDLE, you can NOT disable periodic email checking.

It's always possible that the IMAP server decides not to push new email to your client because it's too busy (like the 17 minute queue I mentioned above), or because it has temporarily disabled IDLE notifications (my proxyserver was messing with those things on purpose !). That's why you still need the periodic polling.

Bug 449021 would help to explain the IDLE setting for users that do not know about the advanced setting. That would make it easier to disable IDLE if the user doesn't want that (like Ness wants), or to enable it, and disable the polling and only rely on IDLE. It's now also possible to do that, just a bit hard to discover.
bienvenu, what do you think of comment 4?
(Reporter)

Comment 6

6 years ago
Marking as a duplicate of 449021, which I think expresses the GUI issues admirably.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 449021

Comment 7

6 years ago
(In reply to Wayne Mery (:wsmwk) from comment #5)
> bienvenu, what do you think of comment 4?

I'm doubtful that we can explain to non-technical users what IDLE does in the extremely limited space available to us in account settings.
You need to log in before you can comment on or make changes to this bug.