Closed Bug 539916 Opened 10 years ago Closed 9 years ago

Sending invites from a zimbra caldav hosted calendar transmits wrong sender address

Categories

(Calendar :: Provider: CalDAV, defect, major)

Lightning 1.0b1
x86
macOS
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 540410

People

(Reporter: kollien, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; de; rv:1.9.2) Gecko/20100105 Firefox/3.6
Build Identifier: Lightning 1.0b1 and less (nightly builds)

I've same calendars which are hosted on a zinbra caldav server. All but sending invites works nearly perfect. When i send an invite to someone, my sender address is set wrong. Instead of using the address specified in the calendars properties of the lightning addon, it seems a calculated form of "Login-User-ID@fqdn-address-of-the-caldav-server" is used as the senders address. As i'm using a local network, because of the server-name-part, this address can't be reached from outside. I only can test this with a zimbra server, but maybe this is a general error on caldav on local networks? IMO, the address of the calendar properties dialog should always be used as a inviting senders address (f.e. using different mail accounts for private and busyness invitings).

Reproducible: Always

Steps to Reproduce:
1. Create a calendar on a (zimbra) caldav server. F.e. login name is foo, server name is calserv.localdomain.local.
2. In the properties dialog choose a address of the thunderbird accounts. F.e. My.Mailname@domain.tld.
3. Create an event and invite someone. 


Actual Results:  
The address of the inviter is set to "foo@calserv.localdomain.local". This address is the return address for responses of the inviting. 

Expected Results:  
The address should be the one from the properties dialog of the calendar: My.Mailname@domain.tld

Always use the address of the assigned by the properties dialog of the calendar, allow overriding the address in the attendees dialog of the event or allow choosing a address from the thunderbird configured mail accounts. First resolution seems the simplest for me.
Version: unspecified → Lightning 1.0b1
The address chosen seems to be based on alphabetical order of the main/primary account and any aliases one may have on the Zimbra server.  This affects our organization too and we're running 1.0b1 version of Lightning and Zimbra NE 6.0.2.

Example:
Setup a CalDav calendar and specify the email address to use in the Calendar properties: john.doe@primarydomain.com

John Doe has two email addresses, one is a primary and one is an alias:
Primary: john.doe@primarydomain.com
Alias: john.doe@momocyles.com

Since the domain momocycles.com is lower in alphabetical order than the domain primarydomain.com, all invitations are sent out as john.doe@momocycles.com.
I can confirm this. Always the first address in alphabetical order is used.

I'm wondering why not the address in the calendar setup is used, but aliases are retrieved from the calendar server?

There can be circumstances, where someone wants replies to invitations sent to an other address. F.e, when sending invitations from the private account (and calender) for busyness events, i could imagine, that the reply to this should be sent to the busyness account and added to the appropriate calendar.

So i mention to always use the e-mail address assigned to the calendar properties in lightning.
Lightning 1.0b3pre/Fedora 13,
Lightning 1.0b2/Windows 

We went into same issue using zimbra and thundebird w lightning.

I did a tcpdump.
Lightning use ALWAYS the last address received by the server/xml.
The sender address not set to the address, defined in Properties dialogue?



Steps to Reproduce:
1) Add Caldav Calendar 
2) Add Alias Address "bernhard.krieger@domain4.com"
3) Restart TB
4) New event
5) Invite
6) Sender address is set to "bernhard.krieger@domain4.com"


</C:schedule-outbox-URL>
        <C:calendar-user-address-set xmlns:C="urn:ietf:params:xml:ns:caldav">
          <D:href>mailto:berni@domain1.com</D:href>
          <D:href>mailto:bernhard.krieger@domain1.com</D:href>
          <D:href>mailto:b.krieger@domain1.com</D:href>
          <D:href>mailto:b.krieger@domain2.com</D:href>
          <D:href>mailto:b.krieger@domain3.com</D:href>
          <D:href>mailto:b.krieger@domain4.com</D:href>
          <D:href>mailto:bernhard.krieger@domain4.com</D:href>
I wonder if this bug should go into the CalDAV Provider queue, rather than the email scheduling queue.

Sadly, I can't find a way to get the autocratic bugzilla to let me alert anyone to this suggestion.
Component: E-mail based Scheduling (iTIP/iMIP) → Provider: CalDAV
QA Contact: email-scheduling → caldav-provider
I think this is a duplicate or similiar to bug #540410.

I do not understand why my address configured in the lightning calendar updates is not used.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 540410
You need to log in before you can comment on or make changes to this bug.