Accelerator for "Reply To List" not displayed in dropdown menu

NEW
Unassigned

Status

Thunderbird
Message Reader UI
8 years ago
2 years ago

People

(Reporter: hub, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-thunderbird3.1 -)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7
Build Identifier: 

"Reply To List" does not have a keyboard shortcut, at least in the menu.

Reproducible: Always

Steps to Reproduce:
1. Receive a mail from a mailing list
2. Try to use the keyboard to reply.
3.
Actual Results:  
You can't there is not keyboard shortcut.

Expected Results:  
To be able to use a keyboard shortcut like Reply and Reply All have.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird3.1?
OS: Mac OS X → All
Hardware: x86 → All

Comment 1

8 years ago
You mean like CTRL-SHIFT-L?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> You mean like CTRL-SHIFT-L?

Except that the menu does not show it, so I didn't know about it until you named it.
Clearly, we should display the accelerator in the menubar menu.  It would be interesting to know if this bug affects platforms other than Mac.
Summary: "Reply To List" does not have a keyboard shortcut → Accelerator for "Reply To List" not displayed in dropdown menu
Created attachment 425112 [details]
Huh.  It's there on my version…

Strange, the accelerator appears on my copy of Thunderbird.

I'm using "Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-GB; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1"

Hubert, could you let us know which version of Thunderbird you're using, and if possible take a screenshot of the missing accelerator?  I also wonder if an extension is perhaps using that key for something else.  What happens if you hit CTRL-SHIFT-L?

Thanks,
Blake.
(Reporter)

Comment 5

8 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.1.7) Gecko/20100111 Thunderbird/3.0.1

attaching screenshot
(Reporter)

Comment 6

8 years ago
Created attachment 425115 [details]
Here it s not

This is how it looks here.
Could you test it in safe mode, while I download the en-US version, to see if either of those is the problem?

Thanks,
Blake.
(Reporter)

Comment 8

8 years ago
what is "safe mode" ?
http://kb.mozillazine.org/Safe_mode

Basically it's a mode where any extensions are disabled, so that we can see if the problem occurs in the base product.

(By the way, en-US worked for me.)
(Reporter)

Comment 10

8 years ago
Starting in safe mode makes it appear.

After that it is always visible.
(In reply to comment #10)
> Starting in safe mode makes it appear.
> 
> After that it is always visible.

You have plenty of extension installed ?
(Reporter)

Comment 12

8 years ago
ZERO.
I saw the same problem as Hubert, and, like him, starting in safe-mode once fixed it then _and_ for subsequent non-safe-mode invocations.  Unlike Hubert, I do have a bunch of add-ons installed.  

Wild speculation: perhaps safe-mode forces localstore.rdf (or some other persistent store) to be regenerated, which fixes the problem?
(Reporter)

Comment 14

8 years ago
It should be noted that I actually had upgraded from the betas where this feature was not in.
That's true for the profile I'm using also.  That said, I think I've run in safe-mode at least once since that feature was added.
Unless we believed this bug effected a very significant number of user, we wouldn't block on this bug, and even then I have my doubts.
blocking-thunderbird3.1: --- → -
Flags: blocking-thunderbird3.1?
You need to log in before you can comment on or make changes to this bug.