Closed Bug 540030 Opened 10 years ago Closed 10 years ago

Display the error and hide the progress bar if an add-on install fails in the Add-on Manager

Categories

(Firefox for Android Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mfinkle, Assigned: mfinkle)

References

Details

Attachments

(1 file)

If an error occurs while installing an add-on, there is no error indicated. Also, the progress bar just remains visible.
Attached patch patchSplinter Review
* Adds an error msg to the search binding
* Sets the msg if an error occurs
* Uses the platform strings (no l10n impact)
* Hides the progress bar if any error occurs
Assignee: nobody → mark.finkle
Attachment #421901 - Flags: review?(gavin.sharp)
tracking-fennec: --- → ?
Comment on attachment 421901 [details] [diff] [review]
patch

>diff --git a/chrome/content/extensions.js b/chrome/content/extensions.js

>   _installCallback: function ev__installCallback(aItem, aStatus) {

>+      try {
>+        var msg = strings.GetStringFromName("error" + aStatus);
>+      } catch (ex) {
>+        msg = strings.getFormattedStringFromName("unknown.error", [aStatus]);

This should be formatStringFromName(), presumably?

Haven't had a chance to test this, but r=me assuming you have.
Attachment #421901 - Flags: review?(gavin.sharp) → review+
(In reply to comment #2)
> (From update of attachment 421901 [details] [diff] [review])
> >diff --git a/chrome/content/extensions.js b/chrome/content/extensions.js
> 
> >   _installCallback: function ev__installCallback(aItem, aStatus) {
> 
> >+      try {
> >+        var msg = strings.GetStringFromName("error" + aStatus);
> >+      } catch (ex) {
> >+        msg = strings.getFormattedStringFromName("unknown.error", [aStatus]);
> 
> This should be formatStringFromName(), presumably?

Yep

> Haven't had a chance to test this, but r=me assuming you have.

Tested for known errors :)
pushed to default:
http://hg.mozilla.org/mobile-browser/rev/a905d05db9e8
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Is there an extension we can test this against? The problems with lazy click have been fixed too quickly.
Duplicate of this bug: 533813
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.